Для чего эта программа
В начало Вперед

Программа "Проектировщик тротуарной плитки" предназначена для разработки проектов по укладке тротуарной плитки. Позволяет в привлекательной форме представить заказчику варианты оформления участка и согласовать проект.

Основные возможности:
· Использовать любые формы плиток. Нарисовать плитки, отсутствующие в библиотеке.
· Задавать взаимное расположение плиток при укладке. Создание различных узоров.
· Менять цвета любых плиток в созданной схеме укладки.
· Автоматически подсчитать количества плиток с разделением по цветам, в том числе с учетом половинок.
· Проектировать укладку на участке произвольной формы с возможностью оставить "пустоты" внутри.
· Печать проекта.


Чего программа не может
Назад В начало Вперед

· учитывать при укладке бордюры и сливы...
· учитывать при укладке технологические зазоры между плитками...
· использовать геодезические приёмы для рисования участка...

Этого программа в версии 2.2 пока делать не может.

Программа постоянно совершенствуется. Возможно, эти функции уже реализованы в следующих версиях, о чём можно узнать на нашей домашней странице.


Требования к компьютеру

1. Видеокарта с возможностью использовать режим цвета High color (16 бит).
2. Операционная система как минимум Windows 98.
3. Процессор не ниже Pentium/Celeron/K6 200 МГц.
4. Оперативная память не меньше 64 Мб.
5. Дисковое пространство - примерно 5 Мб для установки и от 5 кб до 1-2 Мб для каждого проекта.


О программе

Проектировщик тротуарной плитки. Версия 2.2
Copyright © ЧП Гребенюк С.А., 2004-2014

Домашняя страничка: http://ru.paving-expert.com/
Служба технической поддержки: support@paving-expert.com

Custom Containers Pack (CCPack)
Copyright (c) 1997-99 Sergey Orlik

Delphi Container and Algorithm Library 1.0
Copyright (c) 2000 Ross Judson

EhLib v3.6
Copyright (c) 2001-2004 by Dmitry V. Bolshakov

Toolbar97
Copyright (C) 1998-2004 by Jordan Russell

JEDI VCL 3.31
Copyright (c) 1997, 1998 Fedor Koshevnikov, Igor Pavluk and Serge Korolev
Copyright (c) 2001,2002 SGB Software
Copyright (c) 2007 JEDI Team

DEVRACE FIBPLUS 6.7
Copyright (c) 2007 Devrace Company


Новое в 2.2

Написанное ниже добавлено или исправлено с момента выхода 2.0.

Версия 2.2

Добавлено:

На одном чертеже можно располагать несколько проектов. Каждый проект - это, как и раньше, независимый проект со своими границами и узором. Новый или открытый проект можно добавлять в набор проектов. Переключиться на другой проект можно только после сохранения текущего. Созданные таким образом наборы можно сохранять и в дальнейшем открывать в том же составе.

Проект можно сместить на чертеже вдоль координатных осей на заданное расстояние. Меню "Участок"-"Сместить проект". Это полезно, когда вы совмещаете на одном чертеже несколько проектов.

Все проекты, находящиеся на чертеже, можно экспортировать в файл BMP. Экспорт происходит в том масштабе, какой установлен в данный момент. Меню "Проекты"-"Экспортировать презентацию".

Можно создать окантовку или бордюр. Достаточно выбрать линию, вдоль которой нужна окантовка, задать ширину, отступы и углы сопряжения на концах, узор и цвет. Окантовка будет создана как отдельный проект.

Можно создать клоны проекта. Клоны располагаются на том же чертеже, но не являются самостоятельными проектами. Нельзя изменить их границы, узор или цвет плиток. Они изменяются при изменении родительского проекта.

Можно сохранять и загружать однажды определённые цвета. Это те "Дополнительные цвета", которыми раскрашиваются плитки.

В самом узоре можно создать несколько вариантов расцветок и при заполнении участка укладывать плитки сразу с этой расцветкой.

В "Параметрах" можно задать цвет линий, которыми будут рисоваться плитки на проекте. Теперь это не только чёрный.

Как вызнаете, при перемещениях по чертежу координаты округляются до ближайших делений координатной сетки. Чтобы избежать этого, надо удерживать Ctrl. Так достигается более точное позиционирование. Инструмент "Отметить графический элемент" наоборот, никогда не округлял координаты. Это создавало неудобства при переносе графического элемента на целое число делений. Теперь для этого инструмента удержание клавиши Ctrl имеет обратное действие - округление координат.

При рисовании линии правая кнопка мышки в сочетании с клавишей Shift вызывают выпадающее меню, через которое можно нарисовать линию от точки нажатия мышки до точки, заданной в абсолютных или относительных координатах. При рисовании ломаной линии диалог не исчезает и можно продолжать вводить координаты.

Исправлено:

Устранено "торможение" при открытии и сохранении проектов с большим количеством плитки.

Больше не возникает надпись о том, что заполнение плиткой прервано из-за того, что укладка происходит в несколько слоёв.

Исправлена ситуация c заполнением участка. Если начальная точка лежит на границе, а первый узор в силу своего рисунка и ориентации оказывается за границами участка, то заполнение не происходило. Теперь программа ищет возможность заполнить, начиная с подходящего соседнего узора.

Переделано выделение половинок в редакторе плиток. Раньше при некоторых условиях контур половинки не совпадал с чертежом. Учтено, работа в этом направлении продолжается.

Косметические исправления в интерфейс:

В диалоге выбора и сохранения узора название узора теперь занимает всё доступное место.

Версия 2.1

Добавлено:

В редакторе узоров можно посмотреть как прилегают соседние узоры. Они рисуются там, где установлены красные крестики.

Косметические исправления в интерфейс:

Координаты указателя в левом верхнем углу чертежа (на пересечении размерных линеек), а также координаты всех графических элементов, теперь имеют три знака после запятой.


Лицензия

Лицензия на использование программы "Проектировщик тротуарной плитки"

1. Все авторские права на программу "Проектировщик тротуарной плитки" (в дальнейшем в этом документе - Программа) принадлежат ЧП Гребенюк С.А.

2. ПРОГРАММА ПОСТАВЛЯЕТСЯ ПО ПРИНЦИПУ "AS IS". НИКАКИХ ГАРАНТИЙ НЕ ПРИЛАГАЕТСЯ И НЕ ПРЕДУСМАТРИВАЕТСЯ. ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ РИСК. АВТОР НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ ДАННЫХ, ЛЮБУЮ УПУЩЕННУЮ ВЫГОДУ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

3. Исключительное право на распространение Программы принадлежит ЧП Гребенюк С.А. и уполномоченным посредникам. Список уполномоченных посредников размещён на сайте Программы http://ru.paving-expert.com/2.0/order.html. ЧП Гребенюк С.А. не несет обязательств по копиям Программы, приобретенных у третьих лиц.

4. Вы не можете тиражировать, эмулировать, создавать новые версии, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код Программы другими способами, передавать программу или любые из ее составляющих третьим лицам. Любое такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону. Копирование Программы допускается только для резервного хранения.

Все права, не предоставленные здесь, явно сохраняются за ЧП Гребенюк С.А.

5. Вы можете использовать Программу исключительно для целей, указанных в документации (справочной системе) Программы.

6. Лицензионное соглашение является бессрочным.

7. Приобретение Программы означает, что вы понимаете положения настоящего лицензионного соглашения и согласны с ними.


Известные проблемы

1. Редактор проектов, редактор плиток и редактор узоров
· может наблюдаться эффект: инструмент на панели инструментов выбран, т.е. его кнопка нажата, но не работает. Нужно "отжать" и снова нажать кнопку инструмента.
· может появиться несколько неадекватная реакция программы на смену иструмента: например, информация в статус-окне принадлежит не выделенному элементу, а тому, который был выбран до него; сам выбранный элемент рисуется не тем типом линии и т.п. Эти проблемы связаны исключительно с визуальным отображением и никак не угрожают целостности данных. Нужно "отжать" и снова нажать кнопку инструмента.

2. Редатор плиток, редактор проектов
· площадь считается с некоторыми погрешностями, если среди элементов контура есть дуги.

3. Редактор плиток, окно половинок
· при выделении половинки вместо аккуратного контура получается какой-то ломаный многоугольник

Причины:
1. При рисовании контура плитки получились отрезки нулевой длины. Такое бывает, если два раза щелкнуть мышкой на одном и том же месте - начало и конец совпадут. Удалите их через Список графических элементов.
2. При выделении половинки в выделение попали элементы, которые не должны образовывать контур половинки. Удалите половинку и попробуйте выделить ее еще раз.

4. На "слабых" компьютерах некоторые команды выполняются длительное время. Попытка повторить, отменить команду или отдать другую может вызвать сбой. Не торопите компьютер.

Если у вас возникнут проблемы, не описанные в этом разделе, будем благодарны за сообщения о них в службу технической поддержки.


Быстрый старт

Это обзорный раздел справочного руководства, который поможет понять вам основные моменты работы с программой. Он не объясняет все тонкости работы. Его назначение - помочь вам быстро нарисовать простейшую плитку и заполнить ею некоторый участок. Рекомендуем изучить справочное руководство в таком порядке:
1. Быстрый старт.
2. Справочник.
3. Разделы, содержащие практическую информацию: Редактор плиток, редактор узоров, разработка проектов и т.д.

Впрочем, вы можете сразу перейти к практическим разделам, но возможно, вам при этом прийдется чаще обращаться к справочнику.

Итак, быстрый старт.

После установки программы надо создать базу данных, содержащую:
1. Рисунки плиток. См. Быстрый старт. Этап 1
2. Набор узоров по каждой плитке. Узор - это способ расположения плиток относительно друг друга. См. Быстрый старт. Этап 2

Когда создана база данных с плитками и узорами, можно собственно работать - создавать проекты. Для каждого проекта нужно начертить участок, который будет покрыватся плиткой, выбрать узор, задать начальную точку и ориентацию кладки. См. Быстрый старт. Этап 3


Этап 1. Нарисовать плитку

Для начала работы следует выбрать из базы плиток ту, которой вы собираетесь замостить участок. Если плитки такой формы или размера в базе нет, придется нарисовать новую либо изменить имеющуюся плитку. Это делается в редакторе плиток, который доступен через главное меню главного окна.

Открывается редактор плиток:

Чтобы рисовать плитку, надо либо ее создать (меню Плитки -> Новая ), либо открыть ее (меню Плитки -> Открыть ). Вместо меню можно пользоваться панелью инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Контур плитки рисуется мышкой на чертеже. Контур может состоять из графических элементов - отрезков, ломаных линий и дуг. Как их рисовать подробно описано в разделе Черчение графических объектов.

Важно! При рисовании плитки доступны два типа линий - сплошная и точечная. Выбираются из раскрывающего списка на панели инструментов.

Внешний контур плитки должен быть нарисован сплошной линией.

Нарисованные графические элементы можно изменять. Кнопка Список графических элементов [image] открывает список, где можно откорректировать координаты графических примитивов или удалить их. Подробнее о редактировании графических элементов см. раздел Редактирование графических объектов

В конце работы надо сохранить плитку через меню или кнопку [image] на панели инструментов.

Надо ввести название:

Подробнее о рисовании плиток см. Редактор плиток. Предположим, для пробы мы нарисовали прямоугольник со сторонами 200x100 мм.

Теперь можно переходить ко второму этапу - сложить из плитки узор.


Этап 2. Сложить из плиток узор

Редактор узоров вызывается из окна редактора плиток кнопкой на панели инструментов [image] или через главное меню главного окна -> Редактор узоров.

В нем надо создать новый узор или открыть существующий. После этого разблокируются пункты меню и кнопки на панели инструментов.

Нужно расставить на чертеже плитки так, как они будут выглядеть в узоре. Для каждой плитки нужно выполнить следующее:
1. Отметить на чертеже точку, в которую будет помещена плитка.
2. Открыть окно "Добавить плитку в узор".
3. Выбрать в этом окне плитку.
4. На появившемся в окне изображении плитки выбрать точку, которую программа совместит с точкой, отмеченной на шаге 1 (по умолчанию точкой привязки на плитке принимается базовая точка, с которой начинала рисоваться плитка).
5. В то же окне задать ориентацию плитки (поворот вокруг базовой точки относительно осей координат).
6. И в том же окне нажать кнопку "Добавить в узор".

Кнопка Обозначить место плитки [image] - на чертеже выбирается точка, куда будет помещена плитка.

Если эта точка обозначает самую первую плитку узора, то она будет также базовой точкой узора и обозначаться дополнительной меткой - фиолетовым крестиком.

Кнопка Добавить плитку [image] - открывается окно, в котором выбираем плитку, базовую точку и ориентацию плитки.

И на чертеже с узором, и на плитке точки задаются щелчком левой кнопки мыши. Эти точки отображаются синим крестиком. Координаты можно корректировать в окне с плиткой. Окно с плиткой можно закрывать и открывать - цифры запоминаются. Через правую кнопку мыши вызывается контекстное меню, в котором можно изменить размеры координатной сетки и масштаб отображения чертежа, а так же открыть мини-дисплей.
После добавления плитки в узор метка на чертеже [image] снимается и ее нужно ставить снова, в другом месте. Это сделано специально, чтобы не вставить множество плиток в одно и то же место. Если нужно отредактировать расположение плиток или удалить их из узора, кнопка [image] открывает соответствующее окно.

Чтобы программа смогла заполнить площадь, заданным узором, нужно указать базовые точки, где узор будет повторяться. Для этого надо в окне редактора узоров нажать кнопку [image] и мышкой выбрать точки на чертеже. Чтобы отредактировать расположение соседних узоров или удалить их, кнопка [image] открывает окно, в котором можно сделать это.

Пример, как в конечном итоге выглядит один из вариантов узора образованого прямоугольной плиткой:

В конце работы надо сохранить узор через меню или кнопку [image] на панели инструментов, которые открывают соответствующее окно.

После создания узора или нескольких узоров можно переходить непосредственно к разработке проектов укладки плитки.

Более подробно процесс составления узоров описан в главе Редактор узоров.


Этап 3. Уложить плитку на участок

После того, как нарисованы плитки и узоры, можно приступать к разработке проектов. Проекты создаются в самом первом окне, которое появляется после запуска программы. Проект нужно либо создать (меню Проекты -> Новый ), либо открыть существующий (меню Проекты -> Открыть ). Вместо меню можно пользоваться панелью инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Схема работы такая:
1. Нарисовать участок. Участок рисуется абсолютно аналогично плитке. Нужно использовать кнопки на панели инструментов [image], [image], [image] и [image]. Учтите, что по умолчанию размеры показываются в метрах.

2. Нажмите на панели инструментов кнопку [image] и обозначьте внутри участка точку, с которой начнется заполнение плиткой.

3. Выбрать узор. Кнопка [image].
4. Если нужно, задать ориентацию - угол отклонения узора от горизонтальной оси против часовой стрелки. Кнопка [image].

5. Нажать кнопку Заполнить [image]. Участок заполнится плиткой. Это может продолжаться длительное время.

6. Если нужно изменить цвет плиток, нажмите кнопку Отметить плитку [image] и укажите нужные плитки. Они будут выделены зеленым цветом.

Нажмите правой кнопкой мышки на чертеже и из появившегося меню выберите пункт Изменить цвет. Появится диалог, в котором нужно выбрать необходимый цвет.

Примечание. В разделе "Дополнительные цвета" первый цвет - это цвет плитки по умолчанию. То есть, если надо сделать плитку "нецветной", то нужно назначить ей именно этот цвет.

Теперь проект выглядит так:

В том же меню можно сбросить выделение плиток. Вместо выпадающего меню можно воспользоваться кнопками на панели инструментов [image] и [image].

Еще несколько возможностей нанести цвет на узор.
1. Отметить на участке несколько плиток. Нажать кнопку Размножить выделение [image]. Программа возьмет за точку отсчета плитку, выделенную первой по счету и попытается продолжить цепочку плиток в направлениях от первой до остальных отмеченных. Чтобы понять этот механизм, проделайте следующее:
Отметьте на участке три плитки, как на рисунке ниже, причем первой отметьте левую нижнюю плитку.

Теперь нажмите [image]. Результат будет выглядеть так:

Теперь можно воспользоваться кнопкой Изменить цвет [image].

2. Нажать кнопку Отметить плитку [image]. Теперь если при перемещении указателя мыши над плитками удерживать Shift, плитки будут отмечаться.

Можно получить отчет о количестве использованных плиток с разделением по цветам: меню Участок -> Отчет .

Можно изменить ориентацию, начальную точку, даже узор, и снова заполнить участок.
Когда требуемый результат достигнут, проект можно сохранитьчерез меню или кнопку [image] на панели инструментов и распечатать. Проект сохранятеся на диск в файл с расширением mpp.

На этом мы закончим ознакомление с программой. Информации, изложенной в этой главе, достаточно, чтобы понять возможности программы и создавать простые проекты.
Подробное описание работы с редакторами плиток, узоров и проектов можно найти в главах Редактор плиток, Редактор узоров, Разработка проектов.


Редактор плиток

Чтобы работать с плиткой, надо создать ее заново, в меню Плитки -> Новая или кнопкой [image] на панели инструментов.

Либо открыть существующую через меню Плитки -> Открыть или кнопку [image] на панели инструментов.

После этого разблокируются пункты меню и кнопки на панели инструментов.

Плитка рисуется на чертеже при помощи инструментов Отрезок [image], Ломаная линия [image] и Дуга [image]. Процесс рисования подробно описан в главе Черчение графических объектов. Обратитесь к ней за разъяснениями. Если в процессе рисования обнаружилась ошибка в размерах, можно изменить графические элементы, как это описано в главе Редактирование графических объектов.
Черчение и редактирование графических элементов намеренно вынесено в отдельную главу - те же приемы и методы используются и для черчения участка. Основные моменты будут здесь упоминаться для наглядности.

В редакторе плиток можно рисовать двумя типами линий - сплошной или точечной. Это выбирается из раскрывающего списка на панели инструментов:

Важно! Внешний контур плитки должен быть нарисован сплошной линией. Точечная линия предназначена для рисования декоративных узоров на плитке. Визуально эти типы линий не очень отличаются.

Независимо от того, с чего вы начали рисовать плитку - с контура сплошной линией или сначала декоративный узор точечной линией (что, согласитесь, маловероятно) - первая поставленная на чертеже точка становится базовой. Вокруг нее будет осуществляться поворот при ориентации, отличной от нуля; она будет браться по умолчанию для расположения в узоре. Практическое предназначение этой точки вы поймете, когда начнете выполнять соответствующие действия. Пока просто запомните тот факт, что первая поставленная точка становится базовой. Она отмечается на чертеже фиолетовым крестиком.

Размеры на чертеже плитки указаны всегда в миллиметрах. Это позволяет достичь приемлемой точности при рисовании сложных плиток, особенно содержащих дуги. Если плитка большая, она может не умещаться на экране. Можно уменьшить масштаб кнопкой [image]. Помните, что при этом будет сложнее попасть мышкой точно в требуемую координату. Подробнее о масштабировании чертежа см. Масштаб.

Совет. В главе Черчение графических объектов описан способ рисования в крупном масштабе с Мини-дисплеем.

Если плитка не умещается на чертеже, его размеры можно изменить.

По мере того, как создается контур плитки программа вычисляет площадь плитки и рассчитывает количество плиток на квадратный метр. Эта информация показывается на панели инструментов.

Если у вас возникли подозрения, что цифры не пересчитались после добавления в контур нового элемента, нажмите левой кнопкой мыши непосредственно на надпись. При этом цифры принудительно пересчитываются.
Вместе с площадью и количеством плиток на квадратный метр также показывается толщина плитки. По умолчанию она равна нулю. Толщину можно ввести через меню Чертеж :

В этом же меню можно ввести комментарий к плитке. Это произвольный текст, который вы наберете. Обычно используется для дополнительных сведений, примечаний, рабочих заметок.
В конце работы надо сохранить плитку через меню Плитки -> Сохранить или кнопку [image] на панели инструментов. В открывшемся окне программа запросит подтверждение.

Новая плитка, по умолчанию называется "Безымянная":

Просто нажав ОК, Вы сохраните ее под этим именем в общем списке плиток:

Введите имя плитки:

Введя имя плитки, можно указать набор, в котором ее следует сохранить. Плитка сохранится в составе этого набора, а не в общем списке:

Некоторые плитки поставляются в комплекте (наборе). Как правило, сложить узор из одной плитки этого набора невозможно. Они укладываются вместе, образуя узор из двух и более видов плитки. Имеет смысл сохранять их как отдельный набор. Даже одиночные плитки (узор образует один тип плитки) могут быть разделены на группы по каким-либо признакам (цветные, гладкие и т. д.). Кнопкой Новый набор можно создать набор. В открывшемся окне присвойте ему имя:

Дайте плитке имя и сохраните ее в составе созданного набора:

Другим плиткам из этого же набора не забудьте указать место, где их следует сохранять.

Совет: если плитка ошибочно попала в общий список или не тот набор, откройте ее и сохраните заново через меню Плитки а Сохранить как… Убедившись, что на этот раз все правильно, закройте пересохраненную плитку, откройте плитку сохраненную ошибочно и удалите именно ее.
Примечание: В разных наборах плитки могут иметь одинаковые имена.

При сохранении плитки вместе с ней сохраняются параметры чертежа и масштаб. Когда в следующий раз плитка будет открыта (см. ниже) для редактирования или просмотра, она будет находиться в том же положении, что и была на момент своего сохранения или закрытия редактора.

Открыть существующую плитку для редактирования можно в меню Плитки -> Открыть или кнопкой [image] на панели инструментов. Выбираем из списка плиток нужную и жмем ОК:

Поставив флажок "Предпросмотр", в этом же окне можно предварительно посмотреть на выбранную в библиотеке плитку:

Выбрав плитку, нажимаете "ОК" и она будет открыта в редакторе плиток. Теперь ее можно изменить, сохранить (еще раз) под другим именем, сменить название, удалить.
Важно помнить, что при удалении плитки удаляются все ее узоры и половинки. Если Вы уверены, что открытая плитка не нужна, удалите ее в меню Плитки:

С узорами вы могли ознакоимться в разделе "Быстрый старт", а половинки будут рассмотрены ниже. Из этого же меню имеется возможность экспортировать плитку в точечный рисунок формата BMP. Пункт Экспорт в bmp расположен выше пункта Удалить. Введите имя рисунка в окне "Сохранить как". Контур плитки будет вписан в рисунок 64x64 точки и сохранен на диск.

Если в комплекте форм для плитки есть половинки, их нужно нарисовать тут же. Этому посвящена следующая глава, Половинки.

После создания плитки нужно составить хотя бы один узор с ее использованием. Редактор узоров вызывается через главное меню главного окна. Можно воспользоваться кнопкой [image] на панели инструментов. Кнопка доступны только после того, как плитка сохранена.


Половинки

Если в комплекте форм для плитки есть половинки то разделение плитки на половинки задается в редакторе плиток, поверх нарисованной плитки.
Окно для создания и редактирования половинок вызывается с панели инструментов окна редактора плиток. Кнопка доступна только после того, как плитка сохранена.

Окно имеет вид:

В левой части расположен список наборов половинок, справа - список самих половинок в наборе. Для пояснения о наборах половинок и половинках приведем пример. "Вертикальный разрез" - это набор половинок, а "Левая" и "Правая" - это уже непосредственно половинки.
Вначале добавляется набор половинок. Это делается кнопкой Добавить в левой части окна.
Пусть набор называется "Вертикальный разрез".

Теперь рисуется линия (или несколько линий), разделяющая половинку на части вертикально. Эта линия рисуется теми же инструментами, что и контур плитки. И, как и контур плитки, она должна быть нарисована сплошной линией. Линия разделения отображается синим цветом:

Линия редактируется так же, как и остальные графические элементы.

После этого выделяются половинки. Для этого на панели инструментов есть инструмент [image]. Он задает на экране пунктирные прямоугольники по двум противоположным углам.
· щелчок левой кнопкой мыши - отмечается первый угол
· не отпуская левую кнопку, перетащить мышь в противоположный угол будущего прямоугольника. При этом нужно проследить, чтобы половинка, которая отмечается, полностью попала в прямоугольник, и никакая другая половинка не попала в прямоугольник полностью
· отпустить левую кнопку мыши.

Если все было проделано правильно, половинка добавится в набор и в правой части окна половинок появится название "Безымянная".

Если установить указатель на название половинки, то она выделится на чертеже зеленоватым фоном:

Предупреждение. При выделении половинки вместо аккуратного контура может получаться какой-то ломаный многоугольник:

Причины:
1. При рисовании контура плитки получились отрезки нулевой длины. Такое бывает, если два раза щелкнуть мышкой на одном и том же месте - начало и конец совпадут. Удалите их через Список графических элементов .
2. При выделении половинки в выделение попали элементы, которые не должны образовывать контур половинки. Удалите половинку и попробуйте выделить ее еще раз.

Аналогично добавляется вторая половинка набора:

Аналогично добавляются другие наборы половинок, например, "Горизонтальный разрез":

Нужно подробнее остановиться на названиях половинок. В приведенном примере можно оставить их без изменения - обе "Безымянная". Почему? Потому что они обе предсталяют собой абсолютно одинаковые геометрические фигуры, т.е. при укладке взаимозаменяемы. В этом случае ставим флажок "Взаимозаменяемые". При этом в отчете не будут фигурировать отдельно левая и правая половинки с одинаковым именем "Безымянная", а просто половинка "Вертикальный разрез".

Для пояснения приведем пример. Если бы нужно было вертикально разделить вот такую половинку:

то ни о какой взаимозаменяемости речи быть не может, флажок "Взаимозаменяемые" ставить нельзя, и нужно переименовать половинки в "Левая" и "Правая", чтобы можно было их отличить в отчете

Остальные кнопки в окне половинок:
Слева:
· Редактировать - изменить имя набора половинок
· Удалить - удалить набор половинок
Справа:
· Редактировать - изменить имя половинки
· Удалить - удалить половинку


Редактор узоров

Когда плитка готова, надо в редакторе узоров задать расположение плиток при кладке. Редактор узоров вызывается через главное меню главного окна -> Редактор узоров .
Можно воспользоваться кнопкой [image] на панели инструментов главного окна или окна Редактор плиток.

Назначение узора - показать программе, как именно заполнять участок плиткой. Чтобы задать узор, надо нарисовать его фрагмент. При заполении участка плиткой программа будет помещать на чертеж этот фрагмент, а рядом - такие же фрагменты. Куда именно помещать соседние фрагменты, указывается при составлении узора.

Надо создать новый узор или открыть существующий через меню Узор окна Редактор узоров или кнопки [image] и [image] на панели инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Расставьте на чертеже плитки так, как они будут выглядеть в узоре. Для каждой плитки нужно выполнить следующее:
1. Отметить на чертеже точку, в которую будет помещена плитка.
2. Открыть окно "Добавить плитку в узор".
3. В окне выбрать на плитке точку, которая попадет в точку, отмеченную на шаге 1.
4. В то же окне задать ориентацию плитки.
5. И в том же окне нажать кнопку Добавить в узор .

Ниже подробно описаны эти шаги.

Кнопка Обозначить место плитки [image] - на чертеже выбирается точка, куда будет помещена плитка (в этой главе она называется точка на чертеже )

Если эта точка обозначает самую первую плитку узора, то она будет также базовой точкой узора и обозначаться дополнительной меткой - фиолетовым крестиком.

Кнопка Добавить плитку [image] - открывается окно "Добавить плитку в узор". Здесь выбирается точка плитки, которая будет совмещена с выбранной точкой на чертеже (в этой главе она называется точка на плитке ).

И точка на узоре, и точка на плитке задаются щелчком левой кнопки мыши. Эти точки отображаются синим крестиком. Координаты можно корректировать в окне с плиткой. Окно с плиткой можно закрывать и открывать - цифры запоминаются. Подробнее см. Добавление плитки в узор.

После добавления плитки в узор метка на чертеже [image] снимается и ее нужно ставить снова, в другом месте. Это сделано специально, чтобы не вставить множество плиток в одно и то же место.

Есть более простой способ добавления плитки в узор - кнопка [image]. При этом окно "Добавить плитку..." не открывается. Плитка добавляется в узор в том положении и той точкой на плитке, как она в последний раз была указана в окне "Добавить плитку...". Если точка на плитке еще не была выбрана, ее роль играет базовая точка плитки.

Кнопка [image] открывает окно, в котором можно отредактировать расположение плиток в узоре или удалить их из узора.

Поведение этого списка описано в главе Редактирование графических объектов, за исключением того, что при нажатии Редактировать открывается окно редактирования положения плитки в узоре:

После того, как узор задан, нужно указать базовые точки соседних узоров, чтобы программа смогла заполнить площадь. Для этого надо в окне редактора узоров нажать кнопку [image] и мышкой выбрать точки на чертеже. Кнопка [image] открывает окно, в котором можно отредактировать расположение соседних узоров (точнее базовых точек) или удалить их.

Примеры нескольких возможных узоров из прямоугольной плитки:

На каждом рисунке показан элементарный фрагмент узора. Его базовая точка - в центре. Красными крестиками обозначены точки, куда при заполнении участка плиткой будут помещены соседние узоры (своими базовами точками). Не нужно заботиться о том, чтобы расставить точки во всех направлениях. Программа сама найдет точки в направлениях, противоположных заданным.
Предупреждение. В этой версии программы не решен вопрос о том, как учитывать технологические зазоры при укладке. Есть два варианта решения этой проблемы:
Первый , наиболее простой, но не вполне корректный - рисовать плитку чуть больше реальных размеров. При этом узоры составляются просто и наглядно. Когда алгоритм программы изменится так, что будет учитывать технологические зазоры, прийдется перерисовать все плитки.
Второй вариант - составлять узор с зазорами. При разработке проектов как правило используется довольно мелкий масштаб и зазоры будут незаметны. Единственное неудобство - при проверке узоров будет постоянно выдаваться предупреждение об обнаружении пустот.

В конце работы надо сохранить узор.

Можно открыть существующий узор для редактирования (меню Узоры -> Открыть или кнопка [image] на панели инструментов). Откроется список существующих узоров:

Если поставить флажок "Предпросмотр", то в этом же окне можно посмотреть на указанный узор:

Когда поставлен флажок "Фильтр узоров", сначала выбирается плитка. Становится доступен список узоров, составленных с использованием этой плитки:

Открытый в редакторе плиток узор, можно удалить. Для удаления нужно воспользоваться меню Узор :

Узор можно проверить на отсутствие пустот и наложений плиток. См. главу Проверка узора.


Добавление плитки в узор

В этом окне отображается плитка, из которой составляется узор. На ней нужно обозначить точку, так называемую точку на плитке , которая при добавлении плитки в узор совместится с точкой на чертеже . Точка ставится просто щелчком мыши в нужном месте на чертеже.
Примечание . Однажды обозначенная, точка уже не удаляется с чертежа. Если точку не обозначать, то за точку на плитке принимается базовая точка плитки (обозначена фиолетовым крестиком).

В правой части окна можно ввести точные координаты точки на плитке и точки на чертеже . Изменения координаты набирают силу когда в поле ввода координаты нажать Enter или выйти из этого поля ввода.
Над координатами точек расположено поле ввода ориентации. Здесь задается поворот плитки вокруг базовой точки. Углы отсчитываются как в геометрии - от горизонтальной оси против часовой стрелки. Для узора, пример которого приведен в главе Редактор узоров, плитку нужно повернуть на 90 градусов. Нужно войти в поле Ориентация, набрать "90" и нажать Enter.

Теперь плитка повернута на 90 градусов вокруг базовой точки. При этом она может уйти за пределы видимости.

Когда точка и ориентация выбраны, нужно нажать кнопку Добавить в узор . Плитка будет добавлена в узор. Нужно вернуться в окно с узором, выбрать точку для следующей плитки и повторить все сначала. Но если следующая плитка может быть добавлена с той же выбранной точкой и ориентацией, то окно "Добавить плитку в узор" можно не открывать - есть более простой способ.

Свойства чертежа в этом окне можно изменить через контекстное меню, которое вызывается через правую кнопку мыши на чертеже. Для изменения масштаба и вызова мини-дисплея есть соответствующие кнопки справа.


Проверка узора

Разработанный узор можно проверить, чтобы при укладке не выяснилось:
· плитки в узоре налезают друг на друга
· плитки узоре расположены неплотно, с зазорами
· соседние фрагменты узора налезают друг на друга
· соседние фрагменты узора расположены неплотно, с зазорами

Для этого на панели инструментов редактора узоров есть кнопка:

Программа откроет окно с участком 2х2 метра и заполнит его плиткой, контролируя перечисленные в начале этой главы ошибки. Если все правильно, то после заполнения появится сообщение:

Если, например, точки соседних узоров заданы неправильно, то сообщение будет таким:

В окне с участком можно проанализировать ошибки. Пустоты - синие, наложения - красные. Чтобы не загромождать чертеж, наложения выделены только в первом фрагменте узора. Если устранить их в этом фрагменте, они устанятся везде.

Видимо, соседний нижний узор указан выше, чем нужно, а левый - левее.
Нужно закрыть окно, и исправить точки на узоре. После этого можно повторить проверку.

Помните о предупреждении насчет зазоров.


Разработка проектов

Проекты создаются в самом первом окне, которое появляется после запуска программы. Проект нужно либо создать (меню Проекты -> Новый ), либо открыть существующий (меню Проекты -> Открыть ). После этого разблокируются пункты меню и кнопки на панели инструментов. Вместо меню можно пользоваться панелью инструментов.

Схема работы такая:
1. Нарисовать участок.
2. Обозначить начальную точку.
3. Выбрать узор.
4. Заполнить участок плиткой. Если нужно, предварительно поэкспериментировать с укладкой одного узора.
5. Оформить участок цветом или текстурой.
6. Напечатать результаты.
7. Сохранить участок.

Эти шаги подробно описаны в следующих главах.


Рисование участка

Участок рисуется абсолютно аналогично плитке. Нужно воспользоваться инструментами Отрезок [image] Ломаная линия [image], и Дуга [image]. Процесс рисования подробно описан в главе Черчение графических объектов. Обратитесь к ней за разъяснениями. Если в процессе рисования обнаружилась ошибка в размерах, можно изменить графические элементы, как это описано в главе Редактирование графических объектов.
Черчение и редактирование графических элементов намеренно вынесено в отдельную главу - те же приемы и методы используются и для черчения плитки. Основные моменты будут здесь упоминаться для наглядности.

Контур участка рисуется сплошными линиями. Если проявить аккуратность, в участке точечными линиями можно обозначить бордюры и сливы. Но поскольку операция рисования не-сплошной линией потенциально опасна для участка, и к тому же обработка бордюров и сливов не предусмотрена программой, программа не предоставляет возможности рисовать в проекте точечными линиями. Можно нарисовать все сплошными линиями, а потом нужные линии изменить на точечные.
Размеры на чертеже плитки могут быть указаны в метрах, сантиметрах или миллиметрах. Это можно установить в настройках. Если участок большой, он может не умещаться на экране. Можно уменьшить масштаб кнопкой [image]. Помните, что при этом будет сложнее попасть мышкой точно в требуемую координату. Подробнее о масштабировании чертежа см. Масштаб.
Особенное внимание нужно уделить стыковке линий. Это повлияет на точность вычисления площади участка и на точность заполнения. Если размеры участка замерены с погрешностью и не удается по предоставленным размерам нарисовать замкнутый контур, то допускается нестыковка соседних линий на 50 мм. Эту величину можно изменить в настройках.
Совет. В главе Черчение графических объектов описан способ рисования в крупном масштабе с Мини-дисплеем.
Практический совет: Рисование участка начните с линии, идущей вдоль стены, от порога, ворот, самой длинной или осевой линии участка (короче, той на которую заказчик обратит внимание в первую очередь). Считайте эту линию базовой и сориентируйте ее горизонтально или вертикально. Если не подходит ни одна из границ - временно проведите такую линию, закончив рисовать участок - не торопитесь удалять. Остальные линии границ участка сориентируйте правильно относительно базовой, а относительно осей координат как получится.

Размер участка может быть больше места отведенного для рисования на чертеже, размеры чертежа нужно в этом случае изменить.

Внутри участка можно нарисовать замкнутые контуры, которые не будут заполнены плиткой. Например, клумбы.

После того, как контур готов, надо обозначить точку, с которой будет начинаться заполнение плиткой. Для этого надо нажать на панели инструментов кнопку [image] и щелкнуть мышкой на чертеже в нужной точке. Начальная точка не всегда обозначится точно, задайте ей координаты через меню Участок -> Начальная точка -> Корректировать начальную точку .

Для примера нарисован такой участок:

Примечание. В примере начальная точка произвольна, в реальной работе она скорее всего должна быть расположена на границе или в углу участка. Но не за его пределами!

Теперь можно переходить к следующему этапу - выбрать узор.


Выбор узора

Для выбора узора предназначена кнопка [image].
Открывается окно со списком всех узоров, составленых с использованием всех видов плитки. Если поставить флажок "Предпросмотр", то можно увидеть узор, не открывая его:

Если в окне со списком узоров поставить флажок "Фильтр узоров", то узоры будут доступны после выбора плитки и только те, которые составлены с использованием этой плитки.

После подтверждения выбора узора кнопкой "ОК", в левом верхнем углу окна проекта будет нарисован узор. Это сделано исключительно для того, чтобы помнить, какой именно узор выбран.

Примечание. Если после того как был выбран узор, вы исправляли в соответствующих редакторах его или плитку, из которой узор составлен, нужно заново выбрать узор в проекте.
Иначе изменения не будут внесены в проект.

Плитку не обязательно укладывать по координатным осям, иногда это хочется сделать по какой-то выбранной вами линии или вдоль одной из сторон участка. Для этого задайте ориентацию кладки - угол отклонения узора от горизонтальной оси против часовой стрелки. Кнопка [image].

Совет. Не подбирайте угол, выберите линию нужного направления или временно проведите такую. Угол посмотрите в свойствах линии. Чтобы открыть свойства линии используйте кнопку [image] или кнопку "Редактировать" в cписке границ участка [image]. Также можно отметить линию [image], вызвать контекстное меню щелчком правой клавиши мыши и перейти к пункту "Редактировать". Подробнее в разделе Редактирование графических объектов.

Теперь можно переходить к следующему этапу - заполнение плиткой.


Заполнение плиткой

Нажмите кнопку Заполнить [image] на панели инструментов, или выберите в меню Участок а Заполнить.
Участок заполнится плиткой. Заполнение начинается с того, что в начальную точку помещается выбранный узор. Причем базовая точка этого узора совмещается с начальной точкой. Затем следующие узоры размещаются в заданные точки вокруг предыдущих узоров. Это может продолжаться длительное время. После заполнения появится сообщение и участок будет выглядеть так или, например так:

Что может быть не так?
1. Узор не был проверен и на участке образовались пустоты или плитки спрятались одна под другой.
Надо исправить узор, снова выбрать его и снова нажать [image].
2. Плитки не расположены точно вдоль стороны, к которой они должны примыкать.
Нужно скорректировать начальную точку и снова нажать [image].
3. На участке видны странные незаполненные ничем клинья, проходящие из угла в угол.
Плохо состыкованы линии контура участка. Нужно исправить контур и снова нажать [image].
4. Выдается сообщение и том, что заполнение закончено, но на участке не появилось ни одной плитки.
Начальная точка выбрана неудачно - на участок не попала ни базовая точка первого фрагмента узора, ни базовые точки соседних узоров. Это особенно часто может проявляться, если начальная точка расположена в вершине какого-нибудь остро выступающего угла участка. Перенесите начальную точку.

Рассмотрим вторую проблему подробнее - плитки не расположены точно вдоль стороны, к которой они должны примыкать. Это проявляется когда не совсем удачно выбрана базовая точка узора, например, не на границе одной из плиток, а внутри. Если аналитически рассчитать оптимальное положение начальной точки не удается, можно поэкспериментировать с кнопкой [image]. Она укладывает на участок только один узор, в начальную точку. Можно проверить размещение плиток, скорректировать начальную точку и снова проверить укладку одного узора.

Для удаления всех плиток с участка - предназначена кнопка [image].
Перед повторным заполением не обязательно удалять плитки с участка, нажмите кнопку Заполнить [image] на панели инструментов, или выберите в меню Участок а Заполнить - перед повторным заполнением уложенные ранее плитки удалятся автоматически.

В главе Отчет и комментарий можно найти описание, как проверить количество и расположение половинок.


Оформление участка

Участок можно составить из разноцветных плиток. Это делается уже по готовому заполнению.
Кроме того, можно наложить текстуру, например, "под гранит".

Чтобы изменить цвет плиток, нужно сначала отметить их, а потом изменить им цвет.
Нажмите кнопку Отметить плитку [image] и укажите нужные плитки. Их контур сменит цвет с черного на зеленый.

Если во время выделения удерживать Shift, то будут выделяться плитки, попавшие под курсор мышки. То есть, если нажат Shift, то для выделения плиток не нужно даже нажимать левую кнопку мышки, можно просто перемещать мышку над плитками.

После того, как плитки выделены, нажмите правой кнопкой мышки на чертеже и из появившегося меню выберите пункт Изменить цвет. Появится диалог, в котором нужно выбрать необходимый цвет.

Примечание. В разделе "Дополнительные цвета" первый цвет - это цвет плитки по умолчанию. То есть, если надо сделать плитку "нецветной", то нужно назначить ей именно этот цвет.

В том же меню можно сбросить выделение плиток. Вместо выпадающего меню можно воспользоваться кнопками на панели инструментов [image] и [image]. Теперь проект выглядит так:

Еще несколько возможностей нанести цвет на узор.

1. Простейший случай - равномерно разместить на участке одиночные цветные плитки .Отметить на участке несколько плиток. Нажать кнопку "Размножить выделение" [image]. Программа возьмет за точку отсчета плитку, выделенную первой по счету и попытается продолжить цепочку плиток в направлениях от первой до остальных отмеченных. Чтобы понять этот механизм, проделайте следующее:
Отметьте на участке три плитки, как на рисунке ниже, причем первой отметьте левую нижнюю плитку.

Теперь нажмите [image]. Результат будет выглядеть так:

Теперь можно воспользоваться кнопкой Изменить цвет [image]. После этого не забудьте сбросить выделение плиток. Результат:

При необходимости повторим процедуру:

2. Более сложный случай - равномерное распределение по участку геометрического узора. То же самое, что и в предыдущем случае, но перед размножением надо отметить группу плиток. Нужно как и в первом случае отметить на участке несколько плиток, составляющих геометрический узор. Например:

После этого нажать кнопку [image]. Выделенные плитки сменят контур и зеленоватого на красноватый, и только первая из выделенных останется зеленоватой.

Теперь надо отметить плитки, которые, как и выделенная зеленым, будут первыми в геометрических узорах на своих местах:

После этого надо нажать кнопку Размножить выделение [image]. Результат:

И теперь уже можно изменить цвет. И потом не забыть сбросить веделение.

То же самое в более сложном варианте:

3. Выделить область с плитками.
Это делается при нажатой кнопке Отметить плитку [image], только мышкой, без привлечения других инструментов. Нужно нажать левую кнопку мыши и обвести прямоугольную область.

При этом плитки, хотя бы частично попавшие в область, будут выделены. Выделения областей и отдельные плиток можно повторять:

Чтобы в выделение попали только плитки, попавшие в область целиком, надо при обведении области удерживать Shift.

Более редкий случай оформления - текстура. Она делается проще. Чтобы наложить текстуру, надо нажать кнопку Назначить текстуру [image]. В открывшемся окне выбрать файл с картинкой-текстурой.

Теперь плитки будут нарисованы поверх сплошной заливки "под мрамор".

Удалить текстуру можно кнопкой Удалить текстуру [image]. Чтобы наложить на участок другую текстуру, можно не удалять старую, а сразу назначить новую. Старая удалится автоматически.

Проект можно считать законченным. Можно посмотреть в отчете, сколько плиток предположительно будет израсходовано. Можно ввести комментарий и потом распечатаеть проект вместе с отчетом и комментарием. И в конце работы можно сохранить проект для последующей обработки.


Отчет и комментарий

В отчете можно посмотреть, сколько плиток предположительно будет израсходовано, в том числе половинок. Отчет можно вызвать из меню Участок -> Отчет.
Первая строка отчета - это его площадь и длина периметра, включая периметр внутренних, созданных специально пустот (под клумбы, например).
Далее в столбцах приведены цифры целых плиток и половинок, с разделением по цветам.
Первый столбец - основной цвет, в строках целые плитки, во второй и последующих - половинки каждого вида.
Второй столбец - другой цвет и т. д.
В последнем столбце плитки и половинки каждого вида всех цветов в сумме.
По первому приведенному примеру можно сказать, что целых серых плиток нужно 804 шт. Серых половинок, образованных делением плитки поперек - 28 шт. Серых половинок, образованных делением плитки вдоль - 1 шт. Те же цифры для зеленых плиток - 386 целых, продольных половинок - 22 шт, поперечных - 14 шт.
Плиток всех цветов - 1190 целых, продольных половинок - 50 шт, поперечных - 15 шт.

Когда цветов больше, отчет соответственно изменяется (прибавляются столбцы).

Если узор составлен из плиток нескольких типов, после перечисления целых плиток и половинок одного типа, следуют другие типы. В примере красными линиями соединены цифры с соответствующими плитками и половинками.

Иногда бывает непросто понять - почему именно такое количество половинок, где и как они расположены. На панели инструментов есть кнопка [image]. Если ее нажать, то на участке будут показаны контуры всех половинок. Кнопка имеет свойство оставаться нажатой. Поэтому после повторного заполнения участка половинки будут сразу видны. Чтобы их скрыть, надо "отжать" кнопку.

К проекту можно написать комментарий. Меню Участок -> Комментарий . Здесь можно вписать что угодно, например адрес заказчика.


Печать проекта

Готовый проект можно печатать. Нужно нажать кнопку Печать проекта [image].

Что печатать?
· Контур участка и плитки. Будут напечатаны сам участок, плитки, включая цветные, и текстура. Это потребует значительного расхода чернил или тонера принтера. Поэтому есть вторая возможность:
· Только контур участка. Будет напечатан только контур участка, без плиток и без текстуры. Есть еще одна причина, почему нужно печатать только контур. При большом участке плитки выглядят так мелко, что их контуры образуют сплошной черный фон, то есть печатать их нет смысла.
· Выделенную область участка. В этом случае можно захватить небольшую часть участка, весь он не будет напечатан. В выбранной области напечаются плитки, в том числе и цветные. Этим можно наглядно показать узор. Текстура тоже будет напечатана. В последнем случае нужно иметь уже выделенную для печати область. Если ее нет, программа предложит ее обозначить. Около кнопки печати есть кнопка Выделить область для печати [image]. Теперь нужно нажать мышкой и обвести область, которая должна попасть на принтер. Эта область сохраняется до тех пор, пока нажата кнопка [image]. Если ее "отжать", область печати нужно будет задать заново.

Еще одна опция печати - Отчет и комментарий . Если этот флажок поставить, то на обратной стороне листа напечатается отчет, а под ним - комментарий.


Сохранение проекта

Проект сохранятеся как обычный файл на диске. Меню Проекты ->Сохранить или кнопка Сохранить на панели инструментов.

Ввести имя файла и нажать Сохранить . Файлу присвоится расширение mpp.
В дальнейшем можно открыть проект и работать с ним. Это можно сделать из меню Проекты -> Открыть или кнопкой Открыть [image].


Настройки программы

Настройки программы вызываются из окна проектов через меню Параметры .
В окне две вкладки. На первой можно настроить параметры проектов:

Здесь можно указать, какая размерность будет использована для координатной сетки, на которой рисуется участок. Чаще всего используются метры. Реже - сантиметры.
Также можно указать величину в миллиметрах, в пределах которой концы соседних линий будут считаться соединяющимися, то есть точно состыкованными.

На второй вкладке можно задать аналогичную величину для плиток:


Словарь терминов

Базовая точка
Это самая первая точка плитки, участка или узора. Для плитки и участка это начальная точка графического элемента, который был начерчен самым первым. Для узора - это точка для размещения первой плитки. Повороты (т.е. изменения оринтации) осуществляются вокруг базовой точки. Если удаляется первый графический элемент (из плитки или участка), или первая плитка (из узора), но остальные графические элементы или плитки остаются, то базовая точка не меняется. Базовая точка удаляется только когда удаляются все графические элементы (из плитки или участка), или все плитки (из узора).

Узор
Узор - это расположение плиток при кладке, без учета цвета плиток. Цвет плиток задается позже, уже по готовой кладке. Таким образом, под узором понимается иключительно способ расположения плиток относительно друг друга при кладке. Чтобы задать узор, надо нарисовать его фрагмент. При заполении участка плиткой программа будет помещать на чертеж этот фрагмент, а рядом - такие же фрагменты. Куда именно помещать соседние фрагменты, указывается при составлении узора. Про составление узоров см. Редактор узоров

Графический элемент, графический примитив
Термин позаимствован из компьютерной графики. В этой программе под графическим элементом понимается отрезок прямой или дуга окружности.


Чертеж

Это чертеж, или планшет, или рабочая поверхность - называйте как угодно.
Обладает свойствами:
1. Размеры - высота и ширина.
2. Оси координат - длина положительных участков осей X и Y. Эти длины должны быть меньше соответствующих размеров.
3. Масштаб.

Эти размеры можно изменить через главное меню окна, в котором находится чертеж, через пункт Чертеж -> Размеры .

Кнопки изменения масштаба как правило вынесены на панель инструментов. Подробнее см. Масштаб.

Размерность зависит от чертежа. Для плиток и узоров - всегда миллиметры. Для участка - по умолчанию метры. При желании для участка можно задать размерность в сантиметрах или миллиметрах. См. Настройки. Шаг координатной сетки зависит от размерности. При размерности в миллиметрах и сантиметрах - 1 мм, в метрах - 10 см.

В левом верхнем углу отображаются координаты мыши. Ее перемещение "привязывается" к узлам координатной сетки. Так удобнее рисовать правильные прямоугольники и вообще контролировать размеры. Если нажать Ctrl, то шаг перемещений становится произвольным, не округляется до делений координатной сетки. Практически это означает, что при рисовании отрезки могут начинаться не только в точках пересечения линий сетки, а и внутри ячеек.

Если рисуемый объект большой, но чертить его приходится в крупном масштабе, то для перемещения по чертежу удобно пользоваться Мини-дисплеем.


Черчение графических объектов

В программе можно рисовать три типа графических объектов - отрезок, ломаную линию и дугу. Там, где на чертеже их можно рисовать - в редакторе плиток и в окне разработки проектов - на панели инструментов есть кнопки: Отрезок [image] Ломаная линия [image], и Дуга [image]. Одновременно может быть нажата только одна их них.

Рисование отрезка
Надо нажать кнопку Отрезок [image] на панели инструментов. После этого на чертеже:
· поставить мышку в начало будущего отрезка
· первый щелчок мышкой - начало
· перетащить мышку в конец отрезка, не удерживая левую клавишу. При этом отрезок будет рисоваться пунктиром от начала до текущего положения мышки
· второй щелчок мышкой - конец

Рисование ломаной линии
Надо нажать кнопку Ломаная линия [image] на панели инструментов. После этого на чертеже:
· поставить мышку в начало будущей ломаной линии
· первый щелчок левой клавишей мышки - начало
· перетащить мышку до первого поворота (излома) линии, не удерживая левую клавишу. При этом участок линии будет рисоваться пунктиром от начала до текущего положения мышки
· второй щелчок мышкой - конец участка ломаной линии, точка поворота (излом)
· не удерживая левую клавишу мышки, переместить курсор до следующей точки поворота и снова сделать щелчок левой клавишей
· повторить операцию столько раз, сколько участков ломаной линии требуется нарисовать
· навести курсор мышки на последнюю точку ломаной линии
· сделать щелчок правой (именно правой) клавишей мышки - конец

Рисование дуги
Надо нажать кнопку Дуга [image] на панели инструментов. После этого на чертеже:
· поставить мышку в центр окружности, которой принадлежит дуга
· первый щелчок мышкой - центр
· перетащить мышку, не удерживая левую клавишу, в точку, откуда будет начинаться дуга. При этом пунктиром рисуется окружность
· второй щелчок мышкой - начало
· перетащить мышку, не удерживая левую клавишу, в точку, где дуга будет заканчиваться. При этом будущая дуга рисуется сплошной линией от начала до текущего положения мышки. При чем только против часовой стрелки. Радиус окружности уже не меняется.
· третий щелчок мышкой - конец

Если в процессе расстановки точек для отрезка или дуги нажать не левую клавишу мыши, а правую, то текущий графический элемент "сбрасывается", то есть не будет нарисован.

Если при перемещении мышки удерживать нажатой клавишу Ctrl клавиатуры, то шаг перемещения становится произвольным. Это бывает полезно если координаты начала или конца линии не расположены точно в узлах координатной сетки.

При рисовании нужно следить, чтобы концы линий стыковались как можно точнее. Как описано в главе Чертеж, перемещение мышки "привязывается" с узлам координатной сетки, что облегчает стыковку. Еще проще производить стыковку, если установлен крупный масштаб. Крупный масштаб особенно удобен, если нужно состыковать линии не в узле координатной сетки, а где-нибудь в ячейке, например, в точке с координатами (10,73; 11,8).

Точность стыковки влияет на точность определения площади плитки и чертежа, а также на точность заполнения участка. Концы линий могут не сходиться идеально точно, а быть расположены в допустимых пределах. Для плитки - 10 мм, для чертежа участка - 50 мм. Эти значения можно изменить в настройках программы.

Как нарисовать большой объект, если он не умещается на экране, то есть нужен мелкий масштаб, а точная стыковка требует крупного масштаба? Можно рисовать со включенным мини-дисплеем. При этом по чертежу можно перемещаться не двигая постоянно полосы прокрутки чертежа, а выбирать точку, куда нужно сместиться, щелчком мыши на мини-дисплее. Пример с отрезком:
· обозначить на чертеже начало
· щелкнуть на мини-дисплее примерно туда, где будет конец; при этом изображение чертежа сместится в заданную точку
· на чертеже точно выбрать конечную точку


Редактирование графических объектов

Нарисованный графический объект можно изменить. Первый способ - через окно редактирования свойств. Везде, где его можно вызвать, на панели инструментов есть кнопка Список графических элементов [image]. Она вызывает окно со списком графических элементов.

А уже непосредственно сам графический элемент можно редактировать, нажав кнопку Редактировать . Элемент, выделенный в списке, рисуется на чертеже зеленым цветом.

Отойдем пока от редактирования и рассмотрим другие кнопки окна.
· Удалить - удаляет с чертежа указанный объект
· Выделить все - в списке выделяются все графические элементы. Так их всех можно удалить.

Вернемся к редактированию графического элемента.
По кнопке Редактировать для отрезка открывается окно:

Здесь можно:
· Изменить тип линии. Нужно помнить, что для контура плитки или участка используются только сплошные линии.
· Изменить координаты начала и конца отрезка.
· Изменить длину отрезка. При этом начало отрезка останется на месте, а конец сдвинется вдоль отрезка и координаты конца изментся.
· Изменить угол наклона отрезка от оси X, относительно начала отрезка.
Изменения вступают в силу после нажатия Enter в поле ввода или когда курсор покидает поле ввода.

Ломаная линия, после ее создания, сохраняется как набор отрезков. Каждый отрезок редактируется по отдельности.

Для дуги окно редактирования выглядит так:

Здесь можно:
· Изменить тип линии. Это можно делать только для контура плитки!
· Изменить координаты центра дуги. Дуга при этом переместится, не изменив размеров.
· Изменить координаты начала. При этом дуга переместится по окружности по часовой стрелке или против, изменив радиус, но не изменив угла, который она охватывает на окружности - угол поворота.
· Изменить координаты конца. При этом может измениться радиус дуги, начало дуги может сместиться по радиусу к центру или от центра, и изменяется угол поворота.
· Изменить радиус. Дуга увеличивается или уменьшается в радиусе, остявляя неизменным угол поворота.
· Изменить длину дуги. Изменяется угол поворота, следовательно изменяются координаты конца дуги.
· Изменить угол поворота. Изменения те же, что и при изменении длины.
· Изменить угол начала к оси X. Дуга перемещается по часовой или против часовой стрелке по окружности, не меняя размеры.
Изменения вступают в силу после нажатия Enter в поле ввода или когда курсор покидает поле ввода.

Второй способ редактирования графического элемента - прямо на чертеже. Там, где это можно, на панели инструментов есть кнопка Отметить графический элемент [image]. Теперь если щелкнуть мышкой на графическом элементе, у него на концах появятся метки. Причем метка начала будет голубоватой.

Для дуги отмечается еще и центр.

Теперь можно, перетаскивая мышкой метки, изменять размеры элемента. Это очень удобно использовать при стыковке линий контура.

Если при нажатой кнопке [image] щелкнуть на элементе правой кнопкой мыши, то появится меню:

Первый пункт вызывает окно редактирования элемента, второй - удаляет его с чертежа.


Статус

Для графического элемента, который в данный момент рисуется или выделен, можно отобразить всю инфорамцию о его размерах и координатах. Там, где это можно, на панели инструментов есть кнопка Информация об элементе [image]. Она открывает окно с информацией.
Для отрезка:

Для дуги:


Масштаб

Везде, где предусмотрено изменение масштаба, в окне с чертежом есть три кнопки:
.
Первая увеличивает текущий масштаб вдвое, вторая - вдвое уменьшает. Третья кнопка позволяет установить масштаб точно:

Эти размеры можно изменить через главное меню окна, в котором находится чертеж, через пункт Чертеж -> Масштаб .


Мини-дисплей
Назад В начало

Функция мини-дисплей разработана для быстрого перемещения по большому чертежу. Там , где она доступна, в окне есть кнопка Мини-дисплей [image].
Она вызывает окно с уменьшенной копией рисунка. Щелчок мыши на нем приводит к тому, что окно чертежа перемещается в эту точку.
Например, мы находимся в левой нижней точке чертежа:

Если щелкнуть на мини-дисплее в выделенную на рисунке точку:

то чертеж сместится как показано ниже:

Окно мини-дисплея можно растягивать, что повышает точность позиционирования и перемещения.


.topic 15
Программа "Проектировщик тротуарной плитки" предназначена для разработки проектов по укладке тротуарной плитки. Позволяет в привлекательной форме представить заказчику варианты оформления участка и согласовать проект.

Основные возможности:
Использовать любые формы плиток. Нарисовать плитки, отсутствующие в библиотеке.
Задавать взаимное расположение плиток при укладке. Создание различных узоров.
Менять цвета любых плиток в созданной схеме укладки.
Автоматически подсчитать количества плиток с разделением по цветам, в том числе с учетом половинок.
Проектировать укладку на участке произвольной формы с возможностью оставить "пустоты" внутри.
Печать проекта.

.topic 30
учитывать при укладке бордюры и сливы...
учитывать при укладке технологические зазоры между плитками...
использовать геодезические приёмы для рисования участка...

Этого программа в версии 2.2 пока делать не может.

Программа постоянно совершенствуется. Возможно, эти функции уже реализованы в следующих версиях, о чём можно узнать на нашей домашней странице.

.topic 16
1. Видеокарта с возможностью использовать режим цвета High color (16 бит).
2. Операционная система как минимум Windows 98.
3. Процессор не ниже Pentium/Celeron/K6 200 МГц.
4. Оперативная память не меньше 64 Мб.
5. Дисковое пространство - примерно 5 Мб для установки и от 5 кб до 1-2 Мб для каждого проекта.

.topic 14
Проектировщик тротуарной плитки. Версия 2.2
Copyright © ЧП Гребенюк С.А., 2004-2014

Домашняя страничка: http://ru.paving-expert.com/
Служба технической поддержки: support@paving-expert.com

Custom Containers Pack (CCPack)
Copyright (c) 1997-99 Sergey Orlik

Delphi Container and Algorithm Library 1.0
Copyright (c) 2000 Ross Judson

EhLib v3.6
Copyright (c) 2001-2004 by Dmitry V. Bolshakov

Toolbar97
Copyright (C) 1998-2004 by Jordan Russell

JEDI VCL 3.31
Copyright (c) 1997, 1998 Fedor Koshevnikov, Igor Pavluk and Serge Korolev
Copyright (c) 2001,2002 SGB Software
Copyright (c) 2007 JEDI Team

DEVRACE FIBPLUS 6.7
Copyright (c) 2007 Devrace Company

.topic 60
Написанное ниже добавлено или исправлено с момента выхода 2.0.

Версия 2.2

Добавлено:

На одном чертеже можно располагать несколько проектов. Каждый проект - это, как и раньше, независимый проект со своими границами и узором. Новый или открытый проект можно добавлять в набор проектов. Переключиться на другой проект можно только после сохранения  текущего. Созданные таким образом наборы можно сохранять и в дальнейшем открывать в том же составе.

Проект можно сместить на чертеже вдоль координатных осей на заданное расстояние. Меню "Участок"-"Сместить проект". Это полезно, когда вы совмещаете на одном чертеже несколько проектов.

Все проекты, находящиеся на чертеже, можно экспортировать в файл BMP. Экспорт происходит в том масштабе, какой установлен в данный момент. Меню "Проекты"-"Экспортировать презентацию".

Можно создать окантовку или бордюр. Достаточно выбрать линию, вдоль которой нужна окантовка, задать ширину, отступы и углы сопряжения на концах, узор и цвет. Окантовка будет создана как отдельный проект.

Можно создать клоны проекта. Клоны располагаются на том же чертеже, но не являются самостоятельными проектами. Нельзя изменить их границы, узор или цвет плиток. Они изменяются при изменении родительского проекта.

Можно сохранять и загружать однажды определённые цвета. Это те "Дополнительные цвета", которыми раскрашиваются плитки.

В самом узоре можно создать несколько вариантов расцветок и при заполнении участка укладывать плитки сразу с этой расцветкой.

В "Параметрах" можно задать цвет линий, которыми будут рисоваться плитки на проекте. Теперь это не только чёрный.

Как вызнаете, при перемещениях по чертежу координаты округляются до ближайших делений координатной сетки. Чтобы избежать этого, надо удерживать Ctrl. Так достигается более точное позиционирование. Инструмент "Отметить графический элемент" наоборот, никогда не округлял координаты. Это создавало неудобства при переносе графического элемента на целое число делений. Теперь для этого инструмента удержание клавиши Ctrl имеет обратное действие - округление координат.

При рисовании линии правая кнопка мышки в сочетании с клавишей Shift вызывают выпадающее меню, через которое можно нарисовать линию от точки нажатия мышки до точки, заданной в абсолютных или относительных координатах. При рисовании ломаной линии диалог не исчезает и можно продолжать вводить координаты.

Исправлено:

Устранено "торможение" при открытии и сохранении проектов с большим количеством плитки.

Больше не возникает надпись о том, что заполнение плиткой прервано из-за того, что укладка происходит в несколько слоёв.

Исправлена ситуация c заполнением участка. Если начальная точка лежит на границе, а первый узор в силу своего рисунка и ориентации оказывается за границами участка, то заполнение не происходило. Теперь программа ищет возможность заполнить, начиная с подходящего соседнего узора.

Переделано выделение половинок в редакторе плиток. Раньше при некоторых условиях контур половинки не совпадал с чертежом. Учтено, работа в этом направлении продолжается.

Косметические исправления в интерфейс:

В диалоге выбора и сохранения узора название узора теперь занимает всё доступное место.

Версия 2.1

Добавлено:

В редакторе узоров можно посмотреть как прилегают соседние узоры. Они рисуются там, где установлены красные крестики.

Косметические исправления в интерфейс:

Координаты указателя в левом верхнем углу чертежа (на пересечении размерных линеек), а также координаты всех графических элементов, теперь имеют три знака после запятой.

.topic 48
Лицензия на использование программы "Проектировщик тротуарной плитки"

1. Все авторские права на программу "Проектировщик тротуарной плитки" (в дальнейшем в этом документе - Программа) принадлежат ЧП Гребенюк С.А.

2. ПРОГРАММА ПОСТАВЛЯЕТСЯ ПО ПРИНЦИПУ "AS IS". НИКАКИХ ГАРАНТИЙ НЕ ПРИЛАГАЕТСЯ И НЕ ПРЕДУСМАТРИВАЕТСЯ. ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ РИСК. АВТОР НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ ДАННЫХ, ЛЮБУЮ УПУЩЕННУЮ ВЫГОДУ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ИЛИ НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

3. Исключительное право на распространение Программы принадлежит ЧП Гребенюк С.А. и уполномоченным посредникам. Список уполномоченных посредников размещён на сайте Программы http://ru.paving-expert.com/2.0/order.html. ЧП Гребенюк С.А. не несет обязательств по копиям Программы, приобретенных у третьих лиц.

4. Вы не можете тиражировать, эмулировать, создавать новые версии, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код Программы другими способами, передавать программу или любые из ее составляющих третьим лицам. Любое такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону. Копирование Программы допускается только для резервного хранения.

Все права, не предоставленные здесь, явно сохраняются за ЧП Гребенюк С.А.

5. Вы можете использовать Программу исключительно для целей, указанных в документации (справочной системе) Программы.

6.  Лицензионное соглашение является бессрочным.

7. Приобретение Программы означает, что вы понимаете положения настоящего лицензионного соглашения и согласны с ними.

.topic 31
1. Редактор проектов, редактор плиток и редактор узоров
может наблюдаться эффект: инструмент на панели инструментов выбран, т.е. его кнопка нажата, но не работает. Нужно "отжать" и снова нажать кнопку инструмента.
может появиться несколько неадекватная реакция программы на смену иструмента: например, информация в статус-окне принадлежит не выделенному элементу, а тому, который был выбран до него; сам выбранный элемент рисуется не тем типом линии и т.п. Эти проблемы связаны исключительно с  визуальным отображением и никак не угрожают целостности данных. Нужно "отжать" и снова нажать кнопку инструмента.

2. Редатор плиток, редактор проектов
площадь считается с некоторыми погрешностями, если среди элементов контура есть дуги.

3. Редактор плиток, окно половинок
при выделении половинки вместо аккуратного контура получается какой-то ломаный многоугольник

Причины:
    1. При рисовании контура плитки получились отрезки нулевой длины. Такое бывает, если два раза щелкнуть мышкой на одном и том же месте - начало и конец совпадут. Удалите их через Список графических элементов.
    2. При выделении половинки в выделение попали элементы, которые не должны образовывать контур половинки. Удалите половинку и попробуйте выделить ее еще раз.

4. На "слабых" компьютерах некоторые команды выполняются длительное время. Попытка повторить, отменить команду или отдать другую может вызвать сбой. Не торопите компьютер.

Если у вас возникнут проблемы, не описанные в этом разделе, будем благодарны за сообщения о них в службу технической поддержки.

.topic 13
Это обзорный раздел справочного руководства, который поможет понять вам основные моменты работы с программой. Он не объясняет все тонкости работы. Его назначение - помочь вам быстро нарисовать простейшую плитку и заполнить ею некоторый участок. Рекомендуем изучить справочное руководство в таком порядке:
1. Быстрый старт.
2. Справочник.
3. Разделы, содержащие практическую информацию: Редактор плиток, редактор узоров, разработка проектов и т.д.

Впрочем, вы можете сразу перейти к практическим разделам, но возможно, вам при этом прийдется чаще обращаться к справочнику.

Итак, быстрый старт.

После установки программы надо создать базу данных, содержащую:
1. Рисунки плиток. См. Быстрый старт. Этап 1
2. Набор узоров по каждой плитке. Узор - это способ расположения плиток относительно друг друга. См. Быстрый старт. Этап 2

Когда создана база данных с плитками и узорами, можно собственно работать - создавать проекты. Для каждого проекта нужно начертить участок, который будет покрыватся плиткой, выбрать узор, задать начальную точку и ориентацию кладки. См. Быстрый старт. Этап 3

.topic 10
Для начала работы следует выбрать из базы плиток ту, которой вы собираетесь замостить участок. Если плитки такой формы или размера в базе нет, придется нарисовать новую либо изменить имеющуюся плитку. Это делается в редакторе плиток, который доступен через главное меню главного окна.

Открывается редактор плиток:

Чтобы рисовать плитку, надо либо ее создать (меню Плитки  -> Новая ), либо открыть ее (меню Плитки  -> Открыть ). Вместо меню можно пользоваться панелью инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Контур плитки рисуется мышкой на чертеже. Контур может состоять из графических элементов - отрезков, ломаных линий и дуг. Как их рисовать подробно описано в разделе Черчение графических объектов.

Нарисованные графические элементы можно изменять. Кнопка Список графических элементов   открывает список, где можно откорректировать координаты графических примитивов или удалить их. Подробнее о редактировании графических элементов см. раздел Редактирование графических объектов

В конце работы надо сохранить плитку через меню или кнопку   на панели инструментов.

Надо ввести название:

Подробнее о рисовании плиток см. Редактор плиток. Предположим, для пробы мы нарисовали прямоугольник со сторонами 200x100 мм.

Теперь можно переходить ко второму этапу - сложить из плитки узор.

.topic 11
Редактор узоров вызывается из окна редактора плиток  кнопкой на панели инструментов   или через главное меню главного окна -> Редактор узоров.

В нем надо создать новый узор или открыть существующий. После этого разблокируются пункты меню и кнопки на панели инструментов.

Нужно расставить на чертеже плитки так, как они будут выглядеть в узоре. Для каждой плитки нужно выполнить следующее:
1. Отметить на чертеже точку, в которую будет помещена плитка.
2. Открыть окно "Добавить плитку в узор".
3. Выбрать в этом окне плитку.
4. На появившемся в окне изображении плитки  выбрать точку, которую программа совместит с точкой, отмеченной на шаге 1 (по умолчанию точкой привязки на плитке принимается базовая точка, с которой начинала рисоваться плитка).
5. В то же окне задать ориентацию плитки (поворот вокруг базовой точки относительно осей координат).
6. И в том же окне нажать кнопку "Добавить в узор".

Кнопка Обозначить место плитки   - на чертеже выбирается точка, куда будет помещена плитка.

Если эта точка обозначает самую первую плитку узора, то она будет также базовой точкой узора и обозначаться дополнительной меткой - фиолетовым крестиком.

Кнопка Добавить плитку   - открывается окно, в котором выбираем плитку, базовую точку и ориентацию плитки.

И на чертеже с узором, и на плитке точки задаются щелчком левой кнопки мыши. Эти точки отображаются синим крестиком. Координаты можно корректировать в окне с плиткой. Окно с плиткой можно закрывать и открывать - цифры запоминаются. Через правую кнопку мыши вызывается контекстное меню, в котором можно изменить размеры координатной сетки и масштаб отображения чертежа, а так же открыть мини-дисплей.
После добавления плитки в узор метка на чертеже   снимается и ее нужно ставить снова, в другом месте. Это сделано специально, чтобы не вставить множество плиток в одно и то же место. Если нужно отредактировать расположение плиток или удалить их из узора, кнопка   открывает соответствующее окно.

Чтобы программа смогла заполнить площадь, заданным узором, нужно указать базовые точки, где узор будет повторяться. Для этого надо в окне редактора узоров нажать кнопку   и мышкой выбрать точки на чертеже. Чтобы отредактировать расположение соседних узоров или удалить их, кнопка   открывает окно, в котором можно сделать это.

Пример, как в конечном итоге выглядит один из вариантов узора образованого прямоугольной плиткой:

В конце работы надо сохранить узор через меню или кнопку   на панели инструментов, которые открывают соответствующее окно.

После создания узора или нескольких узоров можно переходить непосредственно к разработке проектов укладки плитки.

Более подробно процесс составления узоров описан в главе Редактор узоров.

.topic 12
После того, как нарисованы плитки и узоры, можно приступать к разработке проектов. Проекты создаются в самом первом окне, которое появляется после запуска программы. Проект нужно либо создать (меню Проекты  -> Новый ), либо открыть существующий (меню Проекты  -> Открыть ). Вместо меню можно пользоваться панелью инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Схема работы такая:
1. Нарисовать участок. Участок рисуется абсолютно аналогично плитке. Нужно использовать кнопки на панели инструментов  ,  ,   и  . Учтите, что по умолчанию размеры показываются в метрах.

2. Нажмите на панели инструментов кнопку   и обозначьте внутри участка точку, с которой начнется заполнение плиткой.

3. Выбрать узор. Кнопка  .
4. Если нужно, задать ориентацию - угол отклонения узора от горизонтальной оси против часовой стрелки. Кнопка  .

5. Нажать кнопку Заполнить  . Участок заполнится плиткой. Это может продолжаться длительное время.

6. Если нужно изменить цвет плиток, нажмите кнопку Отметить плитку   и укажите нужные плитки. Они будут выделены зеленым цветом.

Нажмите правой кнопкой мышки на чертеже и из появившегося меню выберите пункт Изменить цвет. Появится диалог, в котором нужно выбрать необходимый цвет.

Теперь проект выглядит так:

В том же меню можно сбросить выделение плиток. Вместо выпадающего меню можно воспользоваться кнопками на панели инструментов   и  .

Еще несколько возможностей нанести цвет на узор.
1. Отметить на участке несколько плиток. Нажать кнопку Размножить выделение  . Программа возьмет за точку отсчета плитку, выделенную первой по счету и попытается продолжить цепочку плиток в направлениях от первой до остальных отмеченных. Чтобы понять этот механизм, проделайте следующее:
Отметьте на участке три плитки, как на рисунке ниже, причем первой отметьте левую нижнюю плитку.

Теперь нажмите  . Результат будет выглядеть так:

Теперь можно воспользоваться кнопкой Изменить цвет  .

2. Нажать кнопку Отметить плитку  . Теперь если при перемещении указателя мыши над плитками удерживать Shift, плитки будут отмечаться.

Можно получить отчет о количестве использованных плиток с разделением по цветам: меню Участок  -> Отчет .

Можно изменить ориентацию, начальную точку, даже узор, и снова заполнить участок.
Когда требуемый результат достигнут, проект можно сохранитьчерез меню или кнопку   на панели инструментов и распечатать. Проект сохранятеся на диск в файл с расширением mpp.

На этом мы закончим ознакомление с программой. Информации, изложенной в этой главе, достаточно, чтобы понять возможности программы и создавать простые проекты.
Подробное описание работы с редакторами плиток, узоров и проектов можно найти в главах Редактор плиток, Редактор узоров, Разработка проектов.

.topic 4

Чтобы работать с плиткой, надо создать ее заново, в меню Плитки  -> Новая или кнопкой   на панели инструментов.

Либо открыть существующую через меню Плитки  -> Открыть или кнопку   на панели инструментов.

После этого разблокируются пункты меню и кнопки на панели инструментов.

Плитка рисуется на чертеже при помощи инструментов Отрезок  , Ломаная линия   и Дуга  . Процесс рисования подробно описан в главе Черчение графических объектов. Обратитесь к ней за разъяснениями. Если в процессе рисования обнаружилась ошибка в размерах, можно изменить графические элементы, как это описано в главе Редактирование графических объектов.
Черчение и редактирование графических элементов намеренно вынесено в отдельную главу - те же приемы и методы используются и для черчения участка. Основные моменты будут здесь упоминаться для наглядности.

В редакторе плиток можно рисовать двумя типами линий - сплошной или точечной. Это выбирается из раскрывающего списка на панели инструментов:

Независимо от того, с чего вы начали рисовать плитку - с контура сплошной линией или сначала  декоративный узор точечной линией (что, согласитесь, маловероятно) - первая поставленная на чертеже точка становится базовой. Вокруг нее будет осуществляться поворот при ориентации, отличной от нуля; она будет браться по умолчанию для расположения в узоре. Практическое предназначение этой точки вы поймете, когда начнете выполнять соответствующие действия. Пока просто запомните тот факт, что первая поставленная точка становится базовой. Она отмечается на чертеже фиолетовым крестиком.

Размеры на чертеже плитки указаны всегда в миллиметрах. Это позволяет достичь приемлемой точности при рисовании сложных плиток, особенно содержащих дуги. Если плитка большая, она может не умещаться на экране. Можно уменьшить масштаб кнопкой  . Помните, что при этом будет сложнее попасть мышкой точно в требуемую координату. Подробнее о масштабировании чертежа см. Масштаб.

Если плитка не умещается на чертеже, его размеры можно изменить.

По мере того, как создается контур плитки программа вычисляет площадь плитки и рассчитывает количество плиток на квадратный метр. Эта информация показывается на панели инструментов.

Если у вас возникли подозрения, что цифры не пересчитались после добавления в контур нового элемента, нажмите левой кнопкой мыши непосредственно на надпись. При этом цифры принудительно пересчитываются.
Вместе с площадью и количеством плиток на квадратный метр также показывается толщина плитки. По умолчанию она равна нулю. Толщину можно ввести через меню Чертеж :

В этом же меню можно ввести комментарий к плитке. Это произвольный текст, который вы наберете. Обычно используется для дополнительных сведений, примечаний, рабочих заметок.
В конце работы надо сохранить плитку через меню Плитки  -> Сохранить или кнопку   на панели инструментов. В открывшемся окне программа запросит подтверждение.

Новая плитка, по умолчанию называется "Безымянная":

Просто нажав ОК, Вы сохраните ее под этим именем в общем списке плиток:

Введите имя плитки:

Введя имя плитки, можно указать набор, в котором ее следует сохранить. Плитка сохранится в составе этого набора, а не в общем списке:

Некоторые плитки поставляются в комплекте (наборе). Как правило, сложить узор из одной плитки этого набора невозможно. Они укладываются вместе, образуя узор из двух и более видов плитки. Имеет смысл сохранять их как отдельный набор. Даже одиночные плитки (узор образует один тип плитки) могут быть разделены на группы по каким-либо признакам (цветные, гладкие и т. д.). Кнопкой Новый набор можно создать набор. В открывшемся окне присвойте ему имя:

Дайте плитке имя и сохраните ее в составе созданного набора:

Другим плиткам из этого же набора не забудьте указать место, где их следует сохранять.

Совет: если плитка ошибочно попала в общий список или не тот набор, откройте ее и сохраните заново через меню Плитки а Сохранить как… Убедившись, что на этот раз все правильно, закройте пересохраненную плитку, откройте плитку сохраненную ошибочно и удалите именно ее.
Примечание: В разных наборах плитки могут иметь одинаковые имена.

 При сохранении плитки вместе с ней сохраняются параметры чертежа и масштаб. Когда в следующий раз плитка будет открыта (см. ниже) для редактирования или просмотра, она будет находиться в том же положении, что и была на момент своего сохранения или закрытия редактора.

Открыть существующую плитку для редактирования можно в меню Плитки  -> Открыть  или кнопкой   на панели инструментов. Выбираем из списка плиток нужную и жмем ОК:

Поставив флажок "Предпросмотр", в этом же окне можно предварительно посмотреть на выбранную в библиотеке плитку:

Выбрав плитку, нажимаете "ОК" и она будет открыта в редакторе плиток. Теперь ее можно изменить, сохранить (еще раз) под другим именем, сменить название, удалить.
Важно помнить, что  при удалении плитки удаляются все ее узоры и половинки.  Если Вы уверены, что открытая плитка не нужна, удалите ее в меню Плитки:
 #

С узорами вы могли ознакоимться в разделе "Быстрый старт", а половинки будут рассмотрены ниже. Из этого же меню имеется возможность экспортировать плитку в точечный рисунок формата BMP. Пункт Экспорт в  bmp  расположен выше пункта Удалить. Введите имя рисунка в окне "Сохранить как". Контур плитки будет вписан в рисунок 64x64 точки и сохранен на диск.

Если в комплекте форм для плитки есть половинки, их нужно нарисовать тут же. Этому посвящена следующая глава, Половинки.

#После создания плитки нужно составить хотя бы один узор  с ее использованием. Редактор узоров вызывается через главное меню главного окна. Можно воспользоваться кнопкой   на панели инструментов. Кнопка доступны только после того, как плитка сохранена.

.topic 21
Если в комплекте форм для плитки есть половинки то разделение плитки на половинки задается в редакторе плиток, поверх нарисованной плитки.
Окно для создания и редактирования половинок вызывается с панели инструментов окна редактора плиток. Кнопка доступна только после того, как плитка сохранена.

Окно имеет вид:

В левой части расположен список наборов половинок, справа - список самих половинок в наборе. Для пояснения о наборах половинок и половинках приведем пример. "Вертикальный разрез" - это набор половинок, а "Левая" и "Правая" - это уже непосредственно половинки.
Вначале добавляется набор половинок. Это делается кнопкой Добавить  в левой части окна.
Пусть набор называется "Вертикальный разрез".

#Теперь рисуется линия (или несколько линий), разделяющая половинку на части вертикально. Эта линия рисуется теми же инструментами, что и контур плитки. И, как и контур плитки, она должна быть нарисована сплошной линией. Линия разделения отображается синим цветом:

Линия редактируется так же, как и остальные графические элементы.

#После этого выделяются половинки. Для этого на панели инструментов есть инструмент  . Он задает на экране пунктирные прямоугольники по двум противоположным углам.
щелчок левой кнопкой мыши - отмечается первый угол
не отпуская левую кнопку, перетащить мышь в противоположный угол будущего прямоугольника. При этом нужно проследить, чтобы половинка, которая отмечается, полностью попала в прямоугольник, и никакая другая половинка не попала в прямоугольник полностью
отпустить левую кнопку мыши.

Если все было проделано правильно, половинка добавится в набор и в правой части окна половинок появится название "Безымянная".

Если установить указатель на название половинки, то она выделится на чертеже зеленоватым фоном:

Аналогично добавляется вторая половинка набора:

Аналогично добавляются другие наборы половинок, например, "Горизонтальный разрез":

Нужно подробнее остановиться на названиях половинок. В приведенном примере можно оставить их без изменения - обе "Безымянная". Почему? Потому что они обе предсталяют собой абсолютно одинаковые геометрические фигуры, т.е. при укладке взаимозаменяемы. В этом случае ставим флажок "Взаимозаменяемые". При этом в отчете не будут фигурировать отдельно левая и правая половинки с одинаковым именем "Безымянная", а просто половинка "Вертикальный разрез".

Остальные кнопки в окне половинок:
Слева:
Редактировать - изменить имя набора половинок
Удалить - удалить набор половинок
Справа:
Редактировать - изменить имя половинки
Удалить - удалить половинку

.topic 5
Когда плитка готова, надо в редакторе узоров задать расположение плиток при кладке. Редактор узоров вызывается через главное меню главного окна -> Редактор узоров .
 Можно воспользоваться кнопкой   на панели инструментов главного окна или окна Редактор плиток.

Назначение узора - показать программе, как именно заполнять участок плиткой. Чтобы задать узор, надо нарисовать его фрагмент. При заполении участка плиткой программа будет помещать на чертеж этот фрагмент, а рядом - такие же фрагменты. Куда именно помещать соседние фрагменты, указывается при составлении узора.

#Надо создать новый узор или открыть существующий через меню Узор окна Редактор узоров или кнопки   и   на панели инструментов. После этого разблокируются пункты меню и кнопки на панели инструментов.

Расставьте на чертеже плитки так, как они будут выглядеть в узоре. Для каждой плитки нужно выполнить следующее:
1. Отметить на чертеже точку, в которую будет помещена плитка.
2. Открыть окно "Добавить плитку в узор".
3. В окне выбрать на плитке точку, которая попадет в точку, отмеченную на шаге 1.
4. В то же окне задать ориентацию плитки.
5. И в том же окне нажать кнопку Добавить в узор .

Ниже подробно описаны эти шаги.

# Кнопка Обозначить место плитки   - на чертеже выбирается точка, куда будет помещена плитка (в этой главе она называется #точка на чертеже )

Если эта точка обозначает самую первую плитку узора, то она будет также базовой точкой узора и обозначаться дополнительной меткой - фиолетовым крестиком.

# Кнопка Добавить плитку   - открывается окно "Добавить плитку в узор". Здесь выбирается точка плитки, которая будет совмещена с выбранной точкой на чертеже (в этой главе она называется #точка на плитке ).

И точка на узоре, и точка на плитке задаются щелчком левой кнопки мыши. Эти точки отображаются синим крестиком. Координаты можно корректировать в окне с плиткой. Окно с плиткой можно закрывать и открывать - цифры запоминаются. Подробнее см. Добавление плитки в узор.

После добавления плитки в узор метка на чертеже   снимается и ее нужно ставить снова, в другом месте. Это сделано специально, чтобы не вставить множество плиток в одно и то же место.

#Есть более простой способ добавления плитки в узор - кнопка  . При этом окно "Добавить плитку..." не открывается. Плитка добавляется в узор в том положении и той точкой на плитке, как она в последний раз была указана в окне "Добавить плитку...". Если точка на плитке еще не была выбрана, ее роль играет базовая точка плитки.

Кнопка   открывает окно, в котором можно отредактировать расположение плиток в узоре или удалить их из узора.

Поведение этого списка описано в главе Редактирование графических объектов, за исключением того, что при нажатии Редактировать  открывается окно редактирования положения плитки в узоре:

#После того, как узор задан, нужно указать базовые точки соседних узоров, чтобы программа смогла заполнить площадь. Для этого надо в окне редактора узоров нажать кнопку   и мышкой выбрать точки на чертеже. Кнопка   открывает окно, в котором можно отредактировать расположение соседних узоров (точнее базовых точек) или удалить их.

Примеры нескольких возможных узоров из прямоугольной плитки:

На каждом рисунке показан элементарный фрагмент узора. Его базовая точка - в центре. Красными крестиками обозначены точки, куда при заполнении участка плиткой будут помещены соседние узоры (своими базовами точками). Не нужно заботиться о том, чтобы расставить точки во всех направлениях. Программа сама найдет точки в направлениях, противоположных заданным.
#

В конце работы надо сохранить узор.

Можно открыть существующий узор для редактирования (меню Узоры  -> Открыть  или кнопка   на панели инструментов). Откроется список существующих узоров:

Если поставить флажок "Предпросмотр", то в этом же окне можно посмотреть на указанный узор:

Когда поставлен флажок "Фильтр узоров", сначала выбирается плитка. Становится доступен список узоров,  составленных с использованием этой плитки:

Открытый в редакторе плиток узор, можно удалить. Для удаления нужно воспользоваться меню Узор :

Узор можно проверить на отсутствие пустот и наложений плиток. См. главу Проверка узора.

.topic 24

В этом окне отображается плитка, из которой составляется узор. На ней нужно обозначить точку, так называемую точку на плитке , которая при добавлении плитки в узор совместится с точкой на чертеже . Точка ставится просто щелчком мыши в нужном месте на чертеже.

В правой части окна можно ввести точные координаты точки на плитке  и точки на чертеже .  Изменения координаты набирают силу когда в поле ввода координаты нажать Enter или выйти из этого поля ввода.
Над координатами точек расположено поле ввода ориентации. Здесь задается поворот плитки вокруг базовой точки. Углы отсчитываются как в геометрии - от горизонтальной оси против часовой стрелки. Для узора, пример которого приведен в главе Редактор узоров, плитку нужно повернуть на 90 градусов. Нужно войти в поле Ориентация, набрать "90" и нажать Enter.

Теперь плитка повернута на 90 градусов вокруг базовой точки. При этом она может уйти за пределы видимости.

Когда точка и ориентация выбраны, нужно нажать кнопку Добавить в узор . Плитка будет добавлена в узор. Нужно вернуться в окно с узором, выбрать точку для следующей плитки и повторить все сначала. Но если следующая плитка может быть добавлена с той же выбранной точкой и ориентацией, то окно "Добавить плитку в узор" можно не открывать - есть более простой способ.

Свойства чертежа в этом окне можно изменить через контекстное меню, которое вызывается через правую кнопку мыши на чертеже. Для изменения масштаба и вызова мини-дисплея есть соответствующие кнопки справа.

.topic 28
Разработанный узор можно проверить, чтобы при укладке не выяснилось:
плитки в узоре налезают друг на друга
плитки узоре расположены неплотно, с зазорами
соседние фрагменты узора налезают друг на друга
соседние фрагменты узора расположены неплотно, с зазорами

Для этого на панели инструментов редактора узоров есть кнопка:

Программа откроет окно с участком 2х2 метра и заполнит его плиткой, контролируя перечисленные в начале этой главы ошибки. Если все правильно, то после заполнения появится сообщение:

Если, например, точки соседних узоров заданы неправильно, то сообщение будет таким:

В окне с участком можно проанализировать ошибки. Пустоты - синие, наложения - красные. Чтобы не загромождать чертеж, наложения выделены только в первом фрагменте узора. Если устранить их в этом фрагменте, они устанятся везде.

Видимо, соседний нижний узор указан выше, чем нужно, а левый - левее.
Нужно закрыть окно, и исправить точки на узоре. После этого можно повторить проверку.

Помните о предупреждении насчет зазоров.

.topic 6

Проекты создаются в самом первом окне, которое появляется после запуска программы. Проект нужно либо создать (меню Проекты  -> Новый ), либо открыть существующий (меню Проекты  -> Открыть ). После этого разблокируются пункты меню и кнопки на панели инструментов. Вместо меню можно пользоваться панелью инструментов.

Схема работы такая:
1. Нарисовать участок.
2. Обозначить начальную точку.
3. Выбрать узор.
4. Заполнить участок плиткой. Если нужно, предварительно поэкспериментировать с укладкой одного узора.
5. Оформить участок цветом или текстурой.
6. Напечатать результаты.
7. Сохранить участок.

Эти шаги подробно описаны в следующих главах.

.topic 40
Участок рисуется абсолютно аналогично плитке. Нужно воспользоваться инструментами Отрезок   Ломаная линия  , и Дуга  . Процесс рисования подробно описан в главе Черчение графических объектов. Обратитесь к ней за разъяснениями. Если в процессе рисования обнаружилась ошибка в размерах, можно изменить графические элементы, как это описано в главе Редактирование графических объектов.
Черчение и редактирование графических элементов намеренно вынесено в отдельную главу - те же приемы и методы используются и для черчения плитки. Основные моменты будут здесь упоминаться для наглядности.

Контур участка рисуется сплошными линиями. Если проявить аккуратность, в участке точечными линиями можно обозначить бордюры и сливы. Но поскольку операция рисования не-сплошной линией потенциально опасна для участка, и к тому же обработка бордюров и сливов не предусмотрена программой, программа не предоставляет возможности рисовать в проекте точечными линиями. Можно нарисовать все сплошными линиями, а потом нужные линии изменить на точечные.
Размеры на чертеже плитки могут быть указаны в метрах, сантиметрах или миллиметрах. Это можно установить в настройках. Если участок большой, он может не умещаться на экране. Можно уменьшить масштаб кнопкой  . Помните, что при этом будет сложнее попасть мышкой точно в требуемую координату. Подробнее о масштабировании чертежа см. Масштаб.
Особенное внимание нужно уделить стыковке линий. Это повлияет на точность вычисления площади участка и на точность заполнения. Если размеры участка замерены с погрешностью и не удается по предоставленным размерам нарисовать замкнутый контур, то допускается нестыковка соседних линий на 50 мм. Эту величину можно изменить в настройках.

Размер участка может быть больше места отведенного для рисования на чертеже, размеры чертежа нужно в этом случае изменить.

Внутри участка можно нарисовать замкнутые контуры, которые не будут заполнены плиткой. Например, клумбы.

#После того, как контур готов, надо обозначить точку, с которой будет начинаться заполнение плиткой. Для этого надо нажать на панели инструментов кнопку   и щелкнуть мышкой на чертеже в нужной точке.  Начальная точка не всегда обозначится точно, задайте ей координаты через меню Участок  -> Начальная точка  -> Корректировать начальную точку .

Для примера нарисован такой участок:

Теперь можно переходить к следующему этапу - выбрать узор.

.topic 41
Для выбора узора предназначена кнопка  .
Открывается окно со списком всех узоров, составленых с использованием всех видов плитки. Если  поставить флажок "Предпросмотр", то можно увидеть узор, не открывая его:

Если в окне со списком узоров поставить флажок "Фильтр узоров", то узоры будут доступны после выбора плитки и только те, которые составлены с использованием этой плитки.

После подтверждения выбора узора кнопкой "ОК", в левом верхнем углу окна проекта будет нарисован узор. Это сделано исключительно для того, чтобы помнить, какой именно узор выбран.

Плитку не обязательно укладывать по координатным осям, иногда это хочется сделать по какой-то выбранной вами линии или вдоль одной из сторон участка. Для этого задайте ориентацию кладки - угол отклонения узора от горизонтальной оси против часовой стрелки. Кнопка  .

Теперь можно переходить к следующему этапу - заполнение плиткой.

.topic 42
Нажмите кнопку Заполнить   на панели инструментов,  или выберите в меню Участок а Заполнить.
Участок заполнится плиткой. Заполнение начинается с того, что в начальную точку помещается выбранный узор. Причем базовая точка этого узора совмещается с начальной точкой. Затем следующие узоры размещаются в заданные точки вокруг предыдущих узоров. Это может продолжаться длительное время. После заполнения появится сообщение и участок будет выглядеть  так или, например так:

Что может быть не так?
1. Узор не был проверен и на участке образовались пустоты или плитки спрятались одна под другой.
Надо исправить узор, снова выбрать его и снова нажать  .
2. Плитки не расположены точно вдоль стороны, к которой они должны примыкать.
Нужно скорректировать начальную точку и снова нажать  .
3. На участке видны странные незаполненные ничем клинья, проходящие из угла в угол.
Плохо состыкованы линии контура участка. Нужно исправить контур и снова нажать  .
4. Выдается сообщение и том, что заполнение закончено, но на участке не появилось ни одной плитки.
Начальная точка выбрана неудачно - на участок не попала ни базовая точка первого фрагмента узора, ни базовые точки соседних узоров. Это особенно часто может проявляться, если начальная точка расположена в вершине какого-нибудь остро выступающего угла участка. Перенесите начальную точку.

Рассмотрим вторую проблему подробнее - плитки не расположены точно вдоль стороны, к которой они должны примыкать. Это проявляется когда не совсем удачно выбрана базовая точка узора, например, не на границе одной из плиток, а внутри. Если аналитически рассчитать оптимальное положение начальной точки не удается, можно поэкспериментировать с кнопкой  . Она укладывает на участок только один узор, в начальную точку. Можно проверить размещение плиток, скорректировать начальную точку и снова проверить укладку одного узора.

Для удаления всех плиток с участка - предназначена кнопка  .
Перед повторным заполением не обязательно удалять плитки с участка, нажмите кнопку Заполнить   на панели инструментов,  или выберите в меню Участок а Заполнить - перед повторным заполнением  уложенные  ранее плитки удалятся автоматически.

В главе Отчет и комментарий можно найти описание, как проверить количество и расположение половинок.

.topic 43
Участок можно составить из разноцветных плиток. Это делается уже по готовому заполнению.
Кроме того, можно наложить текстуру, например, "под гранит".

Чтобы изменить цвет плиток, нужно сначала отметить их, а потом изменить им цвет.
Нажмите кнопку Отметить плитку   и укажите нужные плитки. Их контур сменит цвет с черного на зеленый.

Если во время выделения удерживать Shift, то будут выделяться плитки, попавшие под курсор мышки. То есть, если нажат Shift, то для выделения плиток не нужно даже нажимать левую кнопку мышки, можно просто перемещать мышку над плитками.

После того, как плитки выделены, нажмите правой кнопкой мышки на чертеже и из появившегося меню выберите пункт Изменить цвет. Появится диалог, в котором нужно выбрать необходимый цвет.

В том же меню можно сбросить выделение плиток. Вместо выпадающего меню можно воспользоваться кнопками на панели инструментов   и  . Теперь проект выглядит так:

Еще несколько возможностей нанести цвет на узор.

1. Простейший случай - равномерно разместить на участке одиночные цветные плитки .Отметить на участке несколько плиток. Нажать кнопку "Размножить выделение"  . Программа возьмет за точку отсчета плитку, выделенную первой по счету и попытается продолжить цепочку плиток в направлениях от первой до остальных отмеченных. Чтобы понять этот механизм, проделайте следующее:
Отметьте на участке три плитки, как на рисунке ниже, причем первой отметьте левую нижнюю плитку.

Теперь нажмите  . Результат будет выглядеть так:

Теперь можно воспользоваться кнопкой Изменить цвет  . После этого не забудьте сбросить выделение плиток. Результат:

При необходимости повторим процедуру:

2. Более сложный случай - равномерное распределение по участку геометрического узора.  То же самое, что и в предыдущем случае, но перед размножением надо отметить группу плиток. Нужно как и в первом случае отметить на участке несколько плиток, составляющих геометрический узор. Например:

После этого нажать кнопку  . Выделенные плитки сменят контур и зеленоватого на красноватый, и только первая из выделенных останется зеленоватой.

Теперь надо отметить плитки, которые, как и выделенная зеленым, будут первыми в геометрических узорах на своих местах:

После этого надо нажать кнопку Размножить выделение  . Результат:

И теперь уже можно изменить цвет. И потом не забыть сбросить веделение.

То же самое в более сложном варианте:

3. Выделить область с плитками.
Это делается при нажатой кнопке Отметить плитку  , только мышкой, без привлечения других инструментов. Нужно нажать левую кнопку мыши и обвести прямоугольную область.

При этом плитки, хотя бы частично попавшие в область, будут выделены. Выделения областей и отдельные плиток можно повторять:

Чтобы в выделение попали только плитки, попавшие в область целиком, надо при обведении области удерживать Shift.

Более редкий случай оформления - текстура. Она делается проще. Чтобы наложить текстуру, надо нажать кнопку Назначить текстуру  . В открывшемся окне выбрать файл с картинкой-текстурой.

Теперь плитки будут нарисованы поверх сплошной заливки "под мрамор".

Удалить текстуру можно кнопкой Удалить текстуру  . Чтобы наложить на участок другую текстуру, можно не удалять старую, а сразу назначить новую. Старая удалится автоматически.

Проект можно считать законченным. Можно посмотреть в отчете, сколько плиток предположительно будет израсходовано. Можно ввести комментарий и потом распечатаеть проект вместе с отчетом и комментарием. И в конце работы можно сохранить проект для последующей обработки.

.topic 33
В отчете можно посмотреть, сколько плиток предположительно будет израсходовано, в том числе половинок. Отчет можно вызвать из меню Участок  -> Отчет.
Первая строка отчета - это его площадь и длина периметра, включая периметр внутренних, созданных специально пустот (под клумбы, например).
Далее в столбцах приведены цифры целых плиток и половинок, с разделением по цветам.
Первый столбец — основной цвет, в строках целые плитки, во второй и последующих —  половинки каждого вида.
Второй столбец — другой цвет и т. д.
В последнем столбце плитки и половинки каждого вида всех цветов в сумме.
По первому приведенному примеру можно сказать, что целых серых плиток нужно 804 шт. Серых половинок, образованных делением плитки поперек - 28 шт. Серых половинок, образованных делением плитки вдоль  - 1 шт. Те же цифры для зеленых плиток - 386 целых, продольных половинок - 22 шт, поперечных - 14 шт.
Плиток всех цветов - 1190 целых, продольных половинок - 50 шт, поперечных - 15 шт.

Когда цветов больше, отчет соответственно изменяется (прибавляются столбцы).

Если узор составлен из плиток нескольких типов, после перечисления целых плиток и половинок одного типа, следуют другие типы. В примере красными линиями соединены цифры с соответствующими плитками и половинками.

Иногда бывает непросто понять - почему именно такое количество половинок, где и как они расположены. На панели инструментов есть кнопка  . Если ее нажать, то на участке будут показаны контуры всех половинок. Кнопка имеет свойство оставаться нажатой. Поэтому после повторного заполнения участка половинки будут сразу видны. Чтобы их скрыть, надо "отжать" кнопку.

#К проекту можно написать комментарий. Меню Участок  -> Комментарий . Здесь можно вписать что угодно, например адрес заказчика.

.topic 44
Готовый проект можно печатать. Нужно нажать кнопку Печать проекта  .

Что печатать?
Контур участка и плитки. Будут напечатаны сам участок, плитки, включая цветные, и текстура. Это потребует значительного расхода чернил или тонера принтера. Поэтому есть вторая возможность:
Только контур участка. Будет напечатан только контур участка, без плиток и без текстуры. Есть еще одна причина, почему нужно печатать только контур. При большом участке плитки выглядят так мелко, что их контуры образуют сплошной черный фон, то есть печатать их нет смысла.
Выделенную область участка. В этом случае можно захватить небольшую часть участка, весь он не будет напечатан. В выбранной области напечаются плитки, в том числе и цветные. Этим можно наглядно показать узор. Текстура тоже будет напечатана. В последнем  случае нужно иметь уже выделенную для печати область. Если ее нет, программа предложит ее обозначить. #Около кнопки печати есть кнопка Выделить область для печати  . Теперь нужно нажать мышкой и обвести область, которая должна попасть на принтер. Эта область сохраняется до тех пор, пока нажата кнопка  . Если ее "отжать", область печати нужно будет задать заново.

Еще одна опция печати - Отчет и комментарий . Если этот флажок поставить, то на обратной стороне листа напечатается отчет, а под ним - комментарий.

.topic 45
Проект сохранятеся как обычный файл на диске. Меню Проекты  ->Сохранить  или кнопка Сохранить  на панели инструментов.

Ввести имя файла и нажать Сохранить . Файлу присвоится расширение mpp.
В дальнейшем можно открыть проект и работать с ним. Это можно сделать из меню Проекты  -> Открыть  или кнопкой Открыть  .

.topic 26
Настройки программы вызываются из окна проектов через меню Параметры .
В окне две вкладки. На первой можно настроить параметры проектов:

Здесь можно указать, какая размерность будет использована для координатной сетки, на которой рисуется участок. Чаще всего используются метры. Реже - сантиметры.
Также можно указать величину в миллиметрах, в пределах которой концы соседних линий будут считаться соединяющимися, то есть точно состыкованными.

На второй вкладке можно задать аналогичную величину для плиток:

.topic 17
#Базовая точка
Это самая первая точка плитки, участка или узора. Для плитки и участка это начальная точка графического элемента, который был начерчен самым первым. Для узора - это точка для размещения первой плитки. Повороты (т.е. изменения оринтации) осуществляются вокруг базовой точки. Если удаляется первый графический элемент (из плитки или участка), или первая плитка (из узора), но остальные графические элементы или плитки остаются, то базовая точка не меняется. Базовая точка удаляется только когда удаляются все графические элементы (из плитки или участка), или все плитки (из узора).

#Узор
Узор - это расположение плиток при кладке, без учета цвета  плиток. Цвет плиток задается позже, уже по готовой кладке. Таким образом, под узором понимается иключительно способ расположения плиток относительно друг друга при кладке. Чтобы задать узор, надо нарисовать его фрагмент. При заполении участка плиткой программа будет помещать на чертеж этот фрагмент, а рядом - такие же фрагменты. Куда именно помещать соседние фрагменты, указывается при составлении узора. Про составление узоров см. Редактор узоров

#Графический элемент, графический примитив
Термин позаимствован из компьютерной графики. В этой программе под графическим элементом понимается отрезок прямой или дуга окружности.

.topic 7

Это чертеж, или планшет, или рабочая поверхность - называйте как угодно.
Обладает свойствами:
1. Размеры - высота и ширина.
2. Оси координат - длина положительных участков осей X и Y. Эти длины должны быть меньше соответствующих размеров.
3. Масштаб.

Эти размеры можно изменить через главное меню окна, в котором находится чертеж, через пункт Чертеж  -> Размеры .

Кнопки изменения масштаба как правило вынесены на панель инструментов. Подробнее см. Масштаб.

Размерность зависит от чертежа. Для плиток и узоров - всегда миллиметры. Для участка - по умолчанию метры. При желании для участка можно задать размерность в сантиметрах или миллиметрах. См. Настройки. Шаг координатной сетки зависит от размерности. При размерности в миллиметрах и сантиметрах - 1 мм, в метрах - 10 см.

В левом верхнем углу отображаются координаты мыши. Ее перемещение "привязывается" к узлам координатной сетки. Так удобнее рисовать правильные прямоугольники и вообще контролировать размеры. Если нажать Ctrl, то шаг перемещений становится произвольным, не округляется до делений координатной сетки. Практически это означает, что при рисовании отрезки могут начинаться не только в точках пересечения линий сетки, а и внутри ячеек.

Если рисуемый объект большой, но чертить его приходится в крупном масштабе, то для перемещения по чертежу удобно пользоваться Мини-дисплеем.

.topic 27
В программе можно рисовать три типа графических объектов - отрезок, ломаную линию и дугу. Там, где на чертеже их можно рисовать - в редакторе плиток и в окне разработки проектов - на панели инструментов есть кнопки: Отрезок   Ломаная линия  , и Дуга  . Одновременно может быть нажата только одна их них.

Рисование отрезка
Надо нажать кнопку Отрезок   на панели инструментов. После этого на чертеже:
поставить мышку в начало будущего отрезка
первый щелчок мышкой - начало
перетащить мышку в конец отрезка, не удерживая левую клавишу. При этом отрезок будет рисоваться пунктиром от начала до текущего положения мышки
второй щелчок мышкой - конец

Рисование ломаной линии
Надо нажать кнопку Ломаная линия   на панели инструментов. После этого на чертеже:
поставить мышку в начало будущей ломаной линии
первый щелчок левой клавишей мышки – начало
перетащить мышку до первого поворота (излома) линии, не удерживая левую клавишу. При этом участок линии будет рисоваться пунктиром от начала до текущего положения мышки
второй щелчок мышкой – конец участка ломаной линии, точка поворота (излом)
не удерживая левую клавишу мышки, переместить курсор до следующей точки поворота и снова сделать щелчок левой клавишей
повторить операцию столько раз, сколько участков ломаной линии требуется нарисовать
навести курсор мышки на последнюю точку ломаной линии
сделать щелчок правой (именно правой) клавишей мышки - конец

Рисование дуги
Надо нажать кнопку Дуга   на панели инструментов. После этого на чертеже:
поставить мышку в центр окружности, которой принадлежит дуга
первый щелчок мышкой - центр
перетащить мышку, не удерживая левую клавишу, в точку, откуда будет начинаться дуга. При этом пунктиром рисуется окружность
второй щелчок мышкой - начало
перетащить мышку, не удерживая левую клавишу, в точку, где дуга будет заканчиваться. При этом будущая дуга рисуется сплошной линией от начала до текущего положения мышки. При чем только против часовой стрелки. Радиус окружности уже не меняется.
третий щелчок мышкой - конец

Если в процессе расстановки точек для отрезка или дуги нажать не левую клавишу мыши, а правую, то текущий графический элемент "сбрасывается", то есть не будет нарисован.

Если при перемещении мышки удерживать нажатой клавишу Ctrl клавиатуры, то шаг перемещения становится произвольным. Это бывает полезно если координаты начала или конца линии не расположены точно в узлах координатной сетки.

При рисовании нужно следить, чтобы концы линий стыковались как можно точнее. Как описано в главе Чертеж, перемещение мышки "привязывается" с узлам координатной сетки, что облегчает стыковку. Еще проще производить стыковку, если установлен крупный масштаб. Крупный масштаб особенно удобен, если нужно состыковать линии не в узле координатной сетки, а где-нибудь в ячейке, например, в точке с координатами (10,73; 11,8).

Точность стыковки влияет на точность определения площади плитки и чертежа, а также на точность заполнения участка. Концы линий могут не сходиться идеально точно, а быть расположены в допустимых пределах. Для плитки - 10 мм, для чертежа участка - 50 мм. Эти значения можно изменить в настройках программы.

#Как нарисовать большой объект, если он не умещается на экране, то есть нужен мелкий масштаб, а точная стыковка требует крупного масштаба? Можно рисовать со включенным мини-дисплеем. При этом по чертежу можно перемещаться не двигая постоянно полосы прокрутки чертежа, а выбирать точку, куда нужно сместиться, щелчком мыши на мини-дисплее. Пример с отрезком:
обозначить на чертеже начало
щелкнуть на мини-дисплее примерно туда, где будет конец; при этом изображение чертежа сместится в заданную точку
на чертеже точно выбрать конечную точку

.topic 29
Нарисованный графический объект можно изменить. Первый способ - через окно редактирования свойств. Везде, где его можно вызвать, на панели инструментов есть кнопка Список графических элементов  . Она вызывает окно со списком графических элементов.

А уже непосредственно сам графический элемент можно редактировать, нажав кнопку Редактировать . Элемент, выделенный в списке, рисуется на чертеже зеленым цветом.

Отойдем пока от редактирования и рассмотрим другие кнопки окна.
Удалить - удаляет с чертежа указанный объект
Выделить все - в списке выделяются все графические элементы. Так их всех можно удалить.

Вернемся к редактированию графического элемента.
#По кнопке Редактировать  для отрезка открывается окно:

Здесь можно:
Изменить тип линии. Нужно помнить, что для контура плитки или участка используются только сплошные линии.
Изменить координаты начала и конца отрезка.
Изменить длину отрезка. При этом начало отрезка останется на месте, а конец сдвинется вдоль отрезка и координаты конца изментся.
Изменить угол наклона отрезка от оси X, относительно начала отрезка.
Изменения вступают в силу после нажатия Enter в поле ввода или когда курсор покидает поле ввода.

Ломаная линия, после ее создания, сохраняется как набор отрезков. Каждый отрезок редактируется по отдельности.

#Для дуги окно редактирования выглядит так:

Здесь можно:
Изменить тип линии. Это можно делать только для контура плитки!
Изменить координаты центра дуги. Дуга при этом переместится, не изменив размеров.
Изменить координаты начала. При этом дуга переместится по окружности по часовой стрелке или против, изменив радиус, но не изменив угла, который она охватывает на окружности - угол поворота.
Изменить координаты конца. При этом может измениться радиус дуги, начало дуги может сместиться по радиусу к центру или от центра, и изменяется угол поворота.
Изменить радиус. Дуга увеличивается или уменьшается в радиусе, остявляя неизменным угол поворота.
Изменить длину дуги. Изменяется угол поворота, следовательно изменяются координаты конца дуги.
Изменить угол поворота. Изменения те же, что и при изменении длины.
Изменить угол начала к оси X. Дуга перемещается по часовой или против часовой стрелке по окружности, не меняя размеры.
Изменения вступают в силу после нажатия Enter в поле ввода или когда курсор покидает поле ввода.

#Второй способ редактирования графического элемента - прямо на чертеже. Там, где это можно, на панели инструментов есть кнопка Отметить графический элемент  . Теперь если щелкнуть мышкой на графическом элементе, у него на концах появятся метки. Причем метка начала будет голубоватой.

Для дуги отмечается еще и центр.

Теперь можно, перетаскивая мышкой метки, изменять размеры элемента. Это очень удобно использовать при стыковке линий контура.

Если при нажатой кнопке   щелкнуть на элементе правой кнопкой мыши, то появится меню:

Первый пункт вызывает окно редактирования элемента, второй - удаляет его с чертежа.

.topic 23
Для графического элемента, который в данный момент рисуется или выделен, можно отобразить всю инфорамцию о его размерах и координатах. Там, где это можно, на панели инструментов есть кнопка Информация об элементе  . Она открывает окно с информацией.
Для отрезка:

Для дуги:

.topic 25
Везде, где предусмотрено изменение масштаба, в окне с чертежом есть три кнопки:
   .
Первая увеличивает текущий масштаб вдвое, вторая - вдвое уменьшает. Третья кнопка позволяет установить масштаб точно:

Эти размеры можно изменить через главное меню окна, в котором находится чертеж, через пункт Чертеж  -> Масштаб .

.topic 22
Функция мини-дисплей разработана для быстрого перемещения по большому чертежу. Там , где она доступна, в окне есть кнопка Мини-дисплей  .
Она вызывает окно с уменьшенной копией рисунка. Щелчок мыши на нем приводит к тому, что окно чертежа перемещается в эту точку.
Например, мы находимся в левой нижней точке чертежа:

Если щелкнуть на мини-дисплее в выделенную на рисунке точку:

то чертеж сместится как показано ниже:

Окно мини-дисплея можно растягивать, что повышает точность позиционирования и перемещения.


.topic 21
Это окно для создания и редактирования половинок. Для подробного объяснения нажмите F1.