Проектировщик тротуарной плитки

Проектировщик тротуарной плитки 2.2

Советы и уроки по использованию программы

Укладка плитки "Старый город"
Как нарисовать "вот такое"


Укладка плитки "Старый город"

Существует несколько разновидностей этого набора, с разным количеством форм и разными размерами форм. Как правило, ширина плиток кратна ширине самой маленькой плитки. Для простоты и наглядности будем считать, что комплект состоит из трёх плиток:
60x120 | 120x120 | 180x120

При составлении узора нужно добиться эффекта случайности чередования плиток. Очевидно, для этого нужно составить несколько рядов плиток и в каждом ряду - значительное количество плиток. Очевидно, в силу того, что все плитки изготовляются комплектом, то и использовать их нужно все. Поэтому в каждый ряд нужно уложить все плитки одного или нескольких комплектов. Вот так выглядит пример из 4-х рядов, в каждый из которых уложено по два комплекта плиток, по шесть штук в ряд:

Итак, случайность в пределах прямоугольника достигнута. Как будет выглядеть кладка? Как строго очерченные дорожки.

Это происходит из-за того, что боковые стороны построенного узора представляют собой прямые линии.

Что нужно сделать? Сместить ряды по горизонтали друг относительно друга. При этом все ряды должны остаться одинаковой длины. Смещать ряды от нулевой отметки нужно на расстояния, кратные ширине самой маленькой плитки. Вот так:

Теперь кладка выгладит хаотично:

P.S.
  1. Получить "правильный" узор из "неправильного" можно получить не только смещением рядов. Достаточно в каждом ряду перенести одну плитку (или несколько) из начала ряда в конец.
  2. При создании узора следует избегать ситуации когда в соседних рядах стыки плиток расположены строго друг над другом. Это несколько портит эффект хаотичности.


Урок 1

Проектировщик тротуарной плитки 2.2

Как нарисовать "вот такое"

В этом уроке будет показано как использовать новую функциональность, которая появилась в версии 2.2.

Этот урок НЕ объясняет:
  • основы рисования геометрических фигур - плиток и проектов
  • создание половинок форм плиток
  • составление узоров
    Это подробно описано в справочном руководстве, прочитайте об этом там. Некоторые другие элементарные вещи будут рассмотрены настолько подробно, насколько это необходимо для объяснения темы урока. За дополнительными объяснениями обратитесь к справочному руководству.
    Прежде всего, давайте условимся - то, что вам поручено нарисовать и уложить, будем называть "рабочим проектом". А то, что мы рисуем и заполняем плиткой в программе будем называть просто "проектом" (по сложившейся ранее терминологии в программе).
    Главной и объединяющей темой урока является "Несколько проектов на одном чертеже". Начните изучение с неё.
    Несколько проектов на одном чертеже
    Размеры чертежа
    Рисование с помощью диалога
    Создание окантовок
    Клонирование проектов
    Заполнение плиткой основного пространства
    Рисование с помощью мини-дисплея
    Собственные цвета
    Заполнение квадратов
    Финальная обработка рабочего проекта


Несколько проектов на одном чертеже

В версии 2.2 на одном чертеже можно разместить несколько проектов. Эти проекты представляют собой абсолютно независимые друг от друга обычные проекты, каждый со своим контуром и узором. Единственное, что их объединяет - это то, что они размещены на одном чертеже. Разумеется, каждый из них можно открыть и отредактировать отдельно от других.
Допустим, вам нужно нарисовать такой рабочий проект:

Здесь ДВА проекта.
Первый - внешний квадрат | Второй - внутренний
Это означает, что надо нарисовать в одном проекте ВСЕ границы внешнего квадрата (обозначены красным), а вдругом прокте - ВСЕ границы внутреннего (обозначены синим).

Все размещённые на чертеже проекты объединены в набор. В наборе можно переключаться между проектами. Текущий выбранный проект становится активным. Его можно редактировать. Остальные в это время недоступны для редактирования.
Рассмотрим наш пример. Поскольку на чертеже могут быть размещены несколько проектов, то при рисовании сложных рабочих проектов можно создать один базовый проект, который будет служить базой для рисования остальных проектов. В нашем случае базовый проект может быть вот таким:

Прежде всего следует установить удобные размеры чертежа. Дальше в примерах масштаб установлен в "1".
Начинаем рисовать. На тулбаре нажимаем кнопку Новый [image]. В редакторе проектов создаётся новый проект "Безымянный". Он добавляется в набор проектов, который пока состоит только из него одного:

Обратите внимание, что на тулбаре стали доступны остальные кнопки. Нарисуем базовый проект. Рисование подробно описано в справочном руководстве. В версии 2.2 можно также рисовать с помощью диалога. Сохраним базовый проект под именем "макет".

Теперь по макету будем создавать окантовки внешних границ рабочего проекта, квадратов и газонов. Каждая линия окантовки - это отдельный проект, который при создании добавляется в набор проектов. С окантовками рабочий проект выглядит так:

А так выглядит набор проектов:

Теперь пора заполнить рабочий проект плиткой. Учитывая, что сказано в начале этой главы про границы проектов, нарисуем проект внутреннего пространства и заполним его плиткой. Работая с несколькими проектами на одном чертеже нужно внимательно следить, какой проект сейчас является активным. Есть риск начать рисовать не в том проекте. Так, окантовки мы создавали на проекте "макет". Если не создать новый проект для внутреннего пространства, то запросто можно начать рисовать прямо в "макете". Поэтому,

не забываем создавать новые проекты для отдельных частей рабочего проекта!

Также нужно сохранять набор проектов после завершения очередного проекта. Допустим, после создания окантовок мы сохранили набор проектов под именем "Урок 1". Затем нарисовали проект "Внутреннее пространство", как на рисунке выше. И решили устроить перерыв в работе, закрыли программу. Когда нужно продолжить работу над рабочим проектом, просто открываем набор проектов. Нажимаем кнопку "Открыть набор" и выбираем файл "Урок 1". Получаем макет с окантовками, но без внутреннего пространства - ранее мы забыли сохранить набор после того, как добавили "Внутреннее пространство":

Это легко исправить. Отмечаем "Новые и открытые проекты добавлять в набор" и просто открываем проект "Внутреннее пространство". Теперь всё выглядит как и должно.

Теперь нужно сохранить набор - мы только что добавили в него проект "Внутреннее пространство". В следующий раз откроется всё вместе.
Создаём проект для заполнения квадратов. Рисуем квадраты.
И опять сохраняем набор.
Итак, работая с несколькими проектами на одном чертеже нужно придерживаться следующего порядка действий:
  1. Создать новый проект
  2. Нарисовать проект
  3. Сохранить проект
  4. Сохранить набор проектов
  5. Перед изменением проекта убедиться, что активным является тот проект, который собираемся менять.
Ненужный проект можно удалить из набора. Для этого его нужно сделать активным и нажать кнопку "Удалить из набора" [image] справа от списка набора проектов. И сохранить набор проектов.

Переходим к финальной обработке рабочего проекта.


Размеры чертежа

Следует установить размеры чертежа, которых нам будет достаточно для создания этого проекта. По умолчанию размеры чертежа 50x50 метров, координатные оси проходят по середине этого пространства. Таким образом, положительная часть осей X и Y составляет 25 м. Для нашего примера это много. Выбираем меню Участок > Размеры. Устанавливаем такие размеры:
Чертёж станет таким:


Рисование с помощью диалога

Нажимаем кнопку "Ломаная линия" [image]. В точке с координатами (0;0) нажимаем правую кнопку мыши, удерживая клавишу Shift. Появится вот такой диалог, а точка (0;0) станет для него текущей. Текущей становится любая точка, в которой мы нажмём <Shift>+<правую кнопку мышки>. Это работает только когда рисуем линию или ломаную линию.

Внизу, в разделе "со смещением от текущей точки" вводим "14" и нажимаем "Вправо".

От текущей точки (0;0) вправо нарисуется линия длиной 14 метров и текущей станет точка (14;0). Значение "14" исчезнет, освобождая ячейку для ввода следующего размера.

Там же вводим "5,6" и нажимаем "Вверх".

Вводим "14" и нажимаем "Влево".

Вводим "5,6" и нажимаем "Вниз".

Если всё сделано правильно, то прямоугольник замкнулся в точке (0;0). Как видите, это удобно использовать, когда известна длина каждого отрезка контура.
Закрываем диалог. Теперь нарисуем нижнюю трапецию. Нажимаем <Shift>+<правую кнопку мышки> в точке (5,4;0). Там же, где и в прошлый раз, вводим "1,2" и нажимаем "Вверх".

Теперь надо нарисовать диагональную линию. Для этого надо использовать две координаты. В среднем разделе, который тоже называется "со смещением от текущей точки" вводим "0,8" и "0,8" по обоим осям и нажимаем "Нарисовать".

Далее внизу вводим "1,6" и нажимаем "Вправо".

Теперь надо нарисовать диагональную линию, но в другом направлении. Поэтому координаты для неё будут "0,8" по X и "-0,8" по Y.

Далее внизу вводим "1,2" и нажимаем "Вниз".

Абсолютно аналогичным образом рисуем верхнюю трапецию. Начинаем из точки (5,4;5,6). Последовательно вводим и нажимаем: "1,2" "Вниз", "0,8" и "-0,8" "Нарисовать", "1,6" "Вправо", "0,8" и "0,8" "Нарисовать", "1,2" "Вверх".

Таким же образом рисуем два квадрата. Первый начинается в точке (1,8;1,8). Для него вводим и нажимаем "2" "Вправо", "2" "Вверх", "2" "Влево", "2" "Вниз". Второй начинается в точке (10,2;1,8). Размеры те же.


Создание окантовок

Окантовка проходит по границам проекта. Обычно по границам укладывается бордюр, но там можно разместить и декоративные элементы. Позже мы рассмотрим бордюр как частный случай окантовки.
Но пока займёмся окантовкой. Окантовку нужно создавать для каждой линии контура проекта. Каждый фрагмент окантовки - это отдельный проект, который при создании добавляется в набор проектов. Поэтому перед созданием окантовки нужно поставить отметку "Новые и открытые проекты добавлять в набор". Выбираем на тулбаре инструмент "Отметить границу участка" [image].
Сначала нарисуем окантовку внешнего контура проекта. В рамках объяснения создания окантовок будем называть его основным проектом.
Нажимаем правую кнопку мышки на нижней границе контура. Граница станет выделенной, и для неё, как и для каждого выделенного графического элемента, откроется popup-меню.

Выбираем "Создать окантовку". Откроется окно создания окантовки.

Прежде всего, мы видим схематическое изображение той границы основного проекта, для которой рисуем окантовку. На схеме длина границы и ширина окантовки показаны не в настоящем размере. Схема нужна только для того, чтобы показать расположение окантовки и форму её концов. Единственный реальный параметр - угол наклона. Он такой же, как и на чертеже. Это сделано чтобы облегчить ориентацию узора. Начало линии обозначено голубым квадратиком, конец - белым.
Немного теории. Мы уже говорили о том, что окантовка - это всего лишь ещё один проект. Следовательно, у него есть свои границы. Границы окантовки - это четырёхугольник, одна из сторон которого опирается на выделенную границу основного проекта. Границы окантовки всегда рисуются по часовой стрелке или от начала выбранной границы основного проекта, или от конца. Перейдём к практике. Введём ширину окантовки. В этом примере она 200 мм. Но размеры в этом окне используются в тех же единицах, что и на основном проекте. Поэтому в поле "Ширина" вводим "0,2".

В соответствии с установками, граница окантовки нарисовалась по часовой стрелке от начала выделенной границы основного проекта. Если указать рисовать от конца, то окантовка нарисуется в другую сторону:

Но нам это не нужно, возвращаем в первоначальное состояние.
Отступы рассмотрим позже.
Сейчас займёмся углами. При помощи них можно сделать различные виды cопряжения фрагментов окантовки. Введём "45" в оба поля.

Обратите внимание, что углы отмеряются не так, как везде в программе.
В программе величина угла всегда отсчитывается от горизонтальной оси, направленной вправо. Таким образом, размер угла всегда возрастает против часовой стрелки. | В окантовке угол просто показывает угол между основанием и торцем окантовки. Направление угла не имеет значения.

Давайте поэкспериментируем с углами для пояснения вышеизложенного. Введём "-30" в поле "в начале окантовки" и "120" в поле "в конце окантовки".

Как видим, в конце окантовки угол 120 отложился от основания. Что происходит в начале окантовки, там где угол отрицательный, -30 ? Там угол отложился от продолжения основания.
Продолжаем создавать окантовку. Возвращаем значение "45" на обоих концах. Нажимаем [image], выбираем имя файла, куда будет сохранён проект окантовки. Назовём его "Окантовка 1".
Далее нужно выбрать узор. Выбранный узор отображается в верхнем левом углу схемы, так же как и в редакторе проектов. Специально для этого примера был создан узор из плитки "Кирпич 100x200", который можно разместить в окантовке поперёк основания.

Заполнить окантовку узором прямо на схеме невозможно, так как на схеме не выдержаны размеры и масштаб, как это было сказано в начале этой главы. Поэтому манипулировать узором прийдётся несколько "наугад".
Для плиток узора можно сразу задать цвет. Это можно сделать и позже, когда проект окантовки будет создан и добавлен в набор проектов, но для этого его нужно будет выбрать в наборе, выделить все плитки и задать цвет. В общем, сейчас это сделать проще. Нажимаем "Выбрать цвет". Выбираем из основных цветов оранжево-коричневый.

Работе с цветами посвящена отдельная глава. Поскольку для окантовки нам не нужны дополнительные цвета, не будем сейчас рассматривать эту тему. Скажем только, что по умолчанию дополнительные цвета для окантовок загружаются из основного проекта. Если нужны другие дополнительные цвета, их можно загрузить тут же, через кнопку "Загрузить цвета".
Осталось повернуть узор, чтобы его угол наклона совпадал с углом наклона основания. Так как основание строго расположено строго горизонтально, оставляем "0" в поле "Ориентация".
Теперь у нас всё готово для создания окантовки. Нажимаем "OK". Создаётся новый проект. Программа спрашивает, нужно ли его сохранить. Сохраняем. Получаем следующий вид в окне проектов:

Здесь уже два проекта: первый - "макет", второй - "Окантовка 1". Это видно в списке проектов:

Обратите внимание, что после создания окантовки она не стала активным проектом. Активным остался "макет". Это удобно, когда нужно создавать множество окантовок. Продолжаем это делать. (Чтобы закрыть список проектов надо выбрать какой-то проект. Сейчас нам нужен "макет", выбираем его простым щелчком мышки)
У нас всё ещё выбран инструмент "Отметить границу участка". Нажимаем правую кнопку мышки на правой границе макета. Выбираем "Создать окантовку". Откроется окно создания окантовки.

Обратите внимание, все параметры, кроме имени проекта, остались от прошлой окантовки. Они нам подходят, кроме ориентации узора. Его нужно развернуть на 90°. Вводим "90" в поле "Ориентация".

Остётся назначить имя проекта для окантовки. Назовём его "Окантовка 2". Нажимаем "OK". Теперь в окне проектов две окантовки.

Создаём окантовку для верхней границы. Опять нужно изменить только ориентацию узора. Она должна быть 180°. Название проекта - "Окантовка 3".

Создадим окантовку для четвёртой границы. Ориентация должна быть 270° (или -90°, что одно и то же).

Теперь начнём создавать окантовки вокруг газонов. Начнём с нижнего. Тут сложнее. Часть границы газона перекрыта окантовкой. На рисунке ниже эта граница отмечена красным.

Выделяем эту линию, вызываем окно создания окантовки. Так оно выглядит после предыдущей окантовки.

Для начала, нужно "развернуть" окантовку внутрь газона. Для этого переставляем переключатель "Нарисовать границы по часовой стрелке" в положение "от конца".

Далее. Нижний срез окантовки - прямой. Поэтому устанавливаем угол в конце в 90°. Обратите внимание, мы нарисовали окантовку от конца выделенной границы основного проекта. Поэтому начало выделенной границы (синий квадратик) и начало окантовки не совпадают. Поэтому мы ввели "90" в конце.
Границы газона сопрягаются под углом 135 градусов. Поэтому угол возле основания окантовки должен быть 135 ⁄ 2 = 67,5°. Учитывая сказанное выше про начало рисования окантовки, "67,5" нужно ввести в поле "в начале окантовки".

Теперь надо "отступить" снизу, чтобы окантовка газона и окантовка внешней границы не перекрывались. Для этого нам понадобятся отступы. Ширина ранее созданной окантовки - 200 мм. На эту же величину нужно сделать отступ. Или, учитывая размерность, на 0,2 метра. Это нужно ввести в поле отступов "в конце окантовки".

Ориентация узора должна быть 270. Это значение осталось с прошлого раза. Оставляем как есть.
Выбираем имя файла для проекта. Пусть будет "Нижняя окантовка 1". Нажимаем "OK".

Продолжаем создавать окантовки по часовой стрелке. Для следующей окантовки углы около оснований 67,5°, без отступов, и ориентация узора -135°.

Следующая окантовка. Углы около оснований 67,5°, без отступов, ориентация узора 180°.

Следующая окантовка. Углы около оснований 67,5°, без отступов, ориентация узора 135°.

Последняя окантовка нижнего газона. По аналогии с первой, понадобится отступ и разные углы возле снования в начале и в конце.

Перейдём к верхнему газону. Там мы будем делать более сложные сопряжения окантовок. Понадобится немного геометрии. Начнём с левой границы.

Вот так должны выглядеть параметры окантовки, если бы мы не собрались делать сложные сопряжения. Вспомним геометрию.

cos A = w ⁄ L ⇒ L = w ⁄ cos A

В нашем случае w - это ширина окантовки, угол A равен 45°. Значит отступ L = 0,2 ⁄ cos 45° = 0,283 (с округлением до трёх знаков). Введём это значение в поле отступа "в конце окантовки". Ориентация должна быть 270°.

Переходим к следующей границе. Отступ в конце окантовки должен быть сделан по той же логике, что и на предыдущем шаге.

Следующая окантовка симметрична и без отступов на концах.

Следующая окантовка похожа на вторую.

Последний элемент окантовки похож на первый.

Теперь перейдём к окантовкам двух квадратов. Здесь не будем сопрягать углы. На углах разместим четыре половинки, сложенные в квадрат. Выделим нижнюю границу левого квадрата.

Поскольку на углах будет другая кладка, введём отступы по 200мм в начале и в конце. Углы на концах должны быть 90°.

Далее выберем левую границу того же квадрата.

Далее нужно нарисовать угол. Это будет отдельный проект, всего 200x200 мм и четырьмя плитками. Чтобы его нарисовать, не нужно вычислять координаты. Можно обрисовать его по макету и границам окантовок. Увеличим масштаб, чтобы точно попадать мышкой в опорные точки. На рисунке ниже опорные точки показаны красным.

Создаём новый проект (кнопка [image]). Обратите внимание, в списке проектов активным стал проект "Безымянный". Выбираем инструмент "Ломаная линия" [image], и рисуем квадрат по опорным точкам. Сохраняем проект под именем "Угол окантовки". Специально для такого угла разработан узор из квадратных плиток 100x100мм. По рисунку ниже видно, как он составлен. Заполним угол этим узором.

Поскольку проект по умолчанию заполняется плитками серого цвета, надо изменить цвет плиток. Подробнее об изменении цвета будет рассказано позже. Полностью этот вопрос описан в справочном руководстве. Выбираем инструмент "Выделить плитку" [image] и выделяем все четыре плитки. Вызываем диалог выбора цвета и выбираем тот же цвет для окантовки.

Сбрасываем выделение (инструмент [image]). Теперь угол окантовки такой же, как и вся окантовка.

Уменьшаем масштаб так, чтобы видеть весь квадрат.

Если присмотреться, то видно, что окантовка верхней границы повторяет окантовку нижней, а окантовка левой границы - окантовку правой. И все четыре угла одинаковы. И они все вместе такие же, как и окантовки другого квадрата. Есть ли другой путь, кроме как рисовать остальные окантовки? Есть - клонирование.

Сохраняем набор проектов кнопкой "Сохранить набор"!

После создания всех окантовок и их клонов можно переходить к заполнению плиткой основного пространства рабочего проекта.


Клонирование проектов

Есть ситуации, когда элементы проекта повторяются в разных местах. На рисунке ниже, если присмотреться, то видно, что окантовка верхней границы квадрата повторяет окантовку нижней, а окантовка левой границы - окантовку правой. И все четыре угла одинаковы. И они все вместе такие же, как и окантовки другого квадрата (его не видно на рисунке). Вместо рисования всех этих копий, можно сделать клоны проекта. Клон - это не проект. Его нельзя изменить - ни границы, ни узор, ни цвет плиток. У клона это всё меняется при изменении в проекте-оригинале. Количество плиток в клоне учитывается в отчёте по проекту.

Начинаем создавать клоны. Так как у нас активным проектом является "Угол окантовки", с него и начнём. На нижнем тулбаре нажимаем кнопку "Клоны проекта" [image].

Начнём с создания клона в правом нижнем углу квадрата. Мы создаём один клон, на том же уровне по высоте, что и оригинал. Это означает, что нужно ввести "1" в поле "Количество" и "1,8" в поле "по оси X на". "1,8" - это 1,8 метра.

В правом нижнем углу появился такой же проект. Обратите внимание, что в списке клонов появилась строка с координатами. Это абсолютные координаты базовой точки клона на чертеже.
Теперь создаём клон в левом верхнем углу.

Теперь клон для правого верхнего угла. Для него нужно смещение 1,8 м по обоим осям.

Принцип понятен, уменьшаем масштаб, чтобы видеть второй квадрат.

Создаём клоны углов для второго квадрата.

С углами закончили. Создадим клоны для окантовок сторон квадрата. Выбираем из списка проектов проект "Горизонтальная окантовка". Ниже показаны координаты клонов для этого проекта.

И то же самое для проекта "Вертикальная окантовка".


Заполнение плиткой основного пространства

Так выглядит рабочий проект после создания окантовок.

Теперь надо нарисовать границы внутреннего пространства. На рисунке ниже они показаны синим.

В этих условиях есть несколько способов нарисовать границы.
  1. В этом уроке мы уже рассматривали как рисовать с помощью диалога рисования линий.
  2. Просто нарисовать линии, как описано в справочном руководстве. При этом прийдётся обводить контуры макета. А для этого нужно точно попадать мышкой в опорные точки, что непросто сделать при маленьком масштабе. А при большом масштабе концы опорной линии могут оказаться за пределами экрана и провести линию из конца в конец не получится.
  3. Для решения проблемы, упомянутой в предыдущем пункте, удобно рисовать с помощью мини-дисплея.
Итак, создаём новый проект, рисуем контуры одним из перечисленных способов, сохраняем проект под названием "Внутреннее пространство" и выбираем для него узор "Кресты 100x200 (простой узор)". Узор покажется в левом верхнем углу чертежа.

Устанавливаем начальную точку [image] в нижний левый угол и заполняем плиткой [image].

Теперь нужно раскрасить плитки. Предварительно прочитайте о том, как создать и сохранить для дальнейшего использования собственные цвета. Предположим, цвета уже созданы, как написано. Надо загрузить их в проект.
Увеличим масштаб, чтобы было нагляднее.
Раскрашивать будем ограниченный фрагмент по шаблону. Этот шаблон распространится по всему пространству проекта. Мысленно (мысленно!) разделим пространство на одинаковые фрагменты. На первый взгяд нужно разделить пространство на прямоугольники, равные по размеру узору.

Но давайте присмотримся. Фрагменты в чётных рядах не аналогичны фрагментам в нечётных рядах. В них плитки уложены по-разному. Значит, не получится распространить цветовой шаблон на все фрагменты.
На самом деле делить надо так:

Или так:

Выбираем первый вариант. Выбираем инструмент "Выделить плитку" [image] и выделяем плитку.

И выбираем такие же плитки в соседних фрагментах по двум разным направлениям. (По двум - потому что фрагменты расположены в ячейках четырёхугольной сетки. Если бы мы заполняли поле шестиугольными плитками, то фрагменты располагались бы в ячейках шестиугольной сетки, и от первой выделенной плитки пришлось бы задавать выделение остальных плиток в трёх различных направлениях)

Нажимаем кнопку "Размножить выделение" [image].

Открываем диалог выбора цвета [image] и выбираем первый созданный нами цвет.

Все выделенные плитки сменят цвет и останутся выделенными:

Нажимаем кнопку "Сбросить выделение" [image]. Получим цветные плитки по всему пространству:

Повторяем те же операции для второй плитки шаблона. Выделяем:

Выбираем цвет:

Сбрасываем выделение и получаем:

Повторяем то же самое для оставшихся двух плиток шаблона, раскрашиваем оставшимися двумя цветами.

Уменьшаем масштаб, оцениваем проект.

Как-то не очень.
Сейчас будем переделывать. Для этого нужно очистить плитки от раскраски. Есть два способа сделать это:
  1. Радикальный. Удалить все плитки [image] и заполнить проект заново.
  2. Присвоить всем плиткам начальный серый цвет.
Рассмотрим второй способ. Выбираем инструмент "Выделить плитку" [image] и обводим мышкой все плитки, удерживая левую кнопку:

Когда отпустим кнопку мышки в правои нижнем углу, все плитки окажутся выделенными:
Напомним: у нас сейчас активным проектом явлется "Внутреннее пространство". Поэтому, выделились только его плитки, хотя мы и обвели мышкой всё, включая плитки окантовки.
Открываем диалог выбора цвета и выбираем цвет плиток по умолчанию.

Раскрашивание плиток группой

 Выбираем масштаб покрупнее, чтобы было удобно работать с выделением плиток. Чтобы получить цветной узор покрасивее, нужно выбирать фрагменты покрупнее.

Или так:

Будем раскрашивать по первому варианту. Выделяем плитки как показано ниже, причём первой выделяем самую левую верхнюю плитку:

Нажимаем кнопку "Запомнить выделенные плитки" [image]. Плитки выделяются красным, а первая из них выделяется ещё и зелёным:

Это означает, что выделенные плитки объединились в группу и первая плитка стала опорной плиткой группы. Выделяем в соседних фрагментах опорные плитки. Они в своих фрагментах расположены там же, где опорная плитка в своём фрагменте.

Нажимаем кнопку "Размножить выделение" [image]. По всему пространству выделятся группы плиток.

Открываем диалог выбора цвета [image] и выбираем первый созданный нами цвет.

Нажимаем кнопку "Сбросить выделение" [image]. Получим цветные плитки по всему пространству:

Раскрашиваем плитки в шаблоне под второй цвет. Повторяем те же шаги. Выделяем плитки:

Нажимаем кнопку "Запомнить выделенные плитки" [image]. Выделяем в соседних фрагментах опорные плитки.

Нажимаем кнопку "Размножить выделение" [image]. По всему пространству выделятся группы плиток.

Открываем диалог выбора цвета [image] и выбираем второй цвет.

После этого сбрасываем выделение и получаем такую картину.

Выделяем плитки в шаблоне под третий цвет и раскрашиваем их.

Выделяем плитки в шаблоне под четвёртый цвет и раскрашиваем их.

В финале получаем вот такую замысловатую расцветку.

Сохраняем проект после всех изменений!

Сохраняем набор проектов кнопкой "Сохранить набор"!

Переходим к заполнению квадратов.


Рисование с помощью мини-дисплея

Допустим, надо нарисовать линии поверх макета по синим линиям:

При маленьком масштабе трудно попадать мышкой в опорные точки. Если увеличить масштаб, то концы опорной линии могут оказаться за пределами экрана и провести линию из конца в конец не получится:

Выход есть - мини-дисплей. Нажимаем кнопку [image] на тулбаре. На рабочем поле появляется панель с уменьшенной копией рабочего проекта:

Важно предварительно установить удобные размеры чертежа. Если размеры чертежа будут чрезмерно большими для рабочего проекта, то мини-дисплей будет выглядеть неинформативно:

Начинаем рисовать контуры. Не забываем создать новый проект для внутреннего пространства рабочего проекта!
Выбираем инструмент "Ломаная линия" [image]. И нажимаем мышкой на мини-дисплее в левый нижний угол (обведено красным кружком):

На рабочей области покажется часть проекта, соответствующая точке нажатия на мини-дисплее. Точность позиционирования зависит от точки нажатия на мини-дисплее.

Наконец-то начинаем рисовать первую линию. Нажимаем в точку начала (на рисунке выше обведена красным кружком). От этой точки потянется линия:

Нажимаем на мини-дисплее в точке окончания линии:

Проект сместится в рабочей области в такое положение:

Завершаем линию. И поскольку мы рисуем ломаную линию, то в этой же точке начинается новая линия. Нажимаем следующую точку на мини-дисплее:

Проект сместился к нужной точке, завершаем линию.

Продолжаем в том же духе для всех опорных точек контура до полного завершения.

Мини-дисплей можно перетащить в любое место рабочей области, как и любое другое окно - за заголовок. Можно изменить его размер, как и любое другое окно - потянув за стороны или углы.


Собственные цвета

По умолчанию в проекте доступны только стандарные цвета и один дополнительный цвет, серый, для нецветных плиток.

Как видите, здесь практически нет цветов, которые можно использовать для плиток. Но можно нажать кнопку "Определить цвета" и создать свои собственные цвета.

Нас будут интересовать значения "Красный", "Зелёный" и "Синий". Величина может варьироваться от 0 до 255.
Красный | Зелёный
Синий | Какой-то песочный цвет

Создаём свой цвет. В списке "Дополнительные цвета" выбираем свободную ячейку.
Важно! Надо предварительно нажать мышкой где-нибудь в цветовом поле - просто ввод значений в поля цветов не будет изменять цвет. Такой глюк наблюдается по крайней мере в Windows XP.
Вводим в "Красный" значение "206", в "Зелёный" - "132", в "Синий" - "103". Нажимаем "Добавить в набор".

Повторяем то же самое ещё раз:
  1. В списке "Дополнительные цвета" выбираем свободную ячейку
  2. Нажимаем мышкой где-нибудь в цветовом поле
  3. Вводим в "Красный" значение "234", в "Зелёный" - "156", в "Синий" - "117"
  4. Нажимаем "Добавить в набор"

Повторяем ещё два раза. Первый набор чисел для цветов - "139", "104" и "82". Второй набор - "99", "72" и "50". В итоге получаем такой набор цветов:

Эти цвета существуют, пока открыто окно, в котором вызывался диалог "Цвет". Чтобы сохранить их для дальнейшего использования, надо их сохранить. Для этого в главном меню вызывающего окна надо воспользоваться пунктом меню "Сохранить цвета". В редакторе проектов он находится в меню "Участок", в редакторе узоров - в "Чертёж". Цвета сохраняются в файл.

Там же находится пункт "Загрузить цвета". Как следует из названия, через него можно загрузить цвета из файла в диалог "Цвет".


Заполнение квадратов

Создаём новый проект, сохраняем его под названием "Квадрат". В главе "Заполнение плиткой основного пространства" мы рассматривали как по существующему макету нарисовать границы проекта. Нам нужно нарисовать квадрат с такими границами:

Рисуем. Выбираем для узор "Стена 100x200 (простой узор)". Устанавливаем начальную точку [image] в нижний левый угол и заполняем плиткой [image].

Раскрасим плитки, как было описано раньше. Помните, что это новый проект, и перед раскраской нужно загрузить цвета. Начальное выделение плиток.

После размножения.

После раскрашивания.

Остальные плитки квадрата раскрашиваем белым аналогичным способом.

Теперь всё выглядит вот так.

Второй квадрат заполняем клонированием.

Сохраняем проект после всех изменений!

Сохраняем набор проектов кнопкой "Сохранить набор"!

Переходим к финальной обработке рабочего проекта.


Финальная обработка рабочего проекта

Экспорт презентации

Зелёные газоны нарисовать в этой версии программы нельзя. Это можно сделать в Paint. А для этого нужно экспортировать рабочий проект в файл-картинку. Выбираем в главном меню редактора проектов Проекты > Экспортировать презентацию. Далее нужно указать имя файла, в который сохранится презентация нашего рабочего проекта. Сохранение проходит пока только в формате BMP.
В зависимости от того, что вы будете дальше делать с этой картинкой, нужно перед экспортом установить масштаб в окне редактора проектов. Экспорт происходит в том же масштабе, в каком вы рассматриваете проект в редакторе проектов. Следовательно, если нужно разместить картинку на сайте, то можно установить масштаб помельче. А если нужно напечатать на плоттере на формате А2, то понадобится масштаб покрупнее.

Отчёт по рабочему проекту

Про отчёт подробно рассказано в справочном руководстве. Здесь остановимся на том, что касается нескольких проектов на одном чертеже и клонах проектов.

Во-первых, отчёт строится суммарно по всем проектам, которые входят в набор. Как видите, плитки белого цвета встречаются только в квадратах, а оранжево-коричневые - только в окантовках. Тем не менее, в отчёте они перечислены наряду с плитками внутреннего пространства. Напротив, плитки светлого кофейно-молочного цвета входят и во внутреннее пространство, и в квадраты. В отчёте же они указаны в общем количестве - 796.
Во-вторых, плитки клонов учитываются так, как если бы они были не клонами, а "настоящими" проектами. То есть к количеству плиток в проекте-оригинале добавляется количество плиток во всех его клонах. Можете пересчитать количество белых плиток в обоих квадратах. В первом их 68. Второй - его клон. Итого белых плиток - 136 шт.
Ещё замечание по отчёту. Общая площадь. Это общая площадь всех проектов набора - внутреннего пространства, квадратов, окантовок - и их клонов. В отчёте показана площадь 131,17 кв.м. Странное число, учитывая, что размеры рабочего проекта 14 м × 5,6 м, итого 78,4 кв.м. Откуда 131,17? Это число включает в себя площадь проекта "макет", который по сути не является частью рабочего проекта. Поэтому перед просмотром отчёта нужно удалить из набора проектов всё лишнее. Удаляем проект "макет" и снова смотрим отчёт. Теперь площадь равна 70,37 кв.м. Это и есть сумма площадей всех проектов набора - площадь прямоугольника 14 × 5,6 минус площадь обоих газонов.

Печать проекта

Как описано в справочном руководстве, можно напечатать:
  • весь проект целиком

  • только контур участка

  • выделенную область

    По умолчанию печатаются все проекты набора. Это можно отключить в окне опций печати. Тогда будет напечатан только активный проект набора.